javaserverfaces
  1. javaserverfaces
  2. JAVASERVERFACES-2803

Detection of f:metadata in ValidateComponentNesting not working

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.5
    • Component/s: view handling
    • Labels:
      None

      Description

      In project stage Development ValidateComponentNesting is used to check if UIViewParameter and UIViewAction are nested within f:metadata. For this, a check is performed if the current component's id equals UIViewRoot.METADATA_FACET_NAME. This is not working correctly, as the metadata UIPanel component's id is null.

      The result of this bug is an incorrect warning message "The metadata component needs to be nested within a f:metadata tag." (the application works as expected).

        Issue Links

          Activity

          Manfred Riem added a comment -

          Verified against 2.2.5 and not able to reproduce.


            People

            • Assignee:
              Manfred Riem
              Reporter:
              michael_kurz
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: