Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.2.0-m13
    • Fix Version/s: 2.2.0-m15
    • Component/s: build
    • Labels:
      None

      Description

      I had to mark several old-style tests as ignored when running on GlassFish 4.0. They all must be addressed before we declare 2.2.0 final.

        Issue Links

          Activity

          Ed Burns added a comment -

          Tests that don't run on GlassFish 4.0 and must do so before declaring
          Mojarra 2.2.0 final.

          SECTION: Modified Files
          ----------------------------
          M jsf-ri/build-tests.xml

          • Cactus tests:

          <test todir="$

          {impl.test.results.dir}"
          name="com.sun.faces.el.TestValueBindingImpl"/>
          <test todir="${impl.test.results.dir}

          "
          name="com.sun.faces.el.TestValueExpressionImpl"/>
          <test todir="$

          {impl.test.results.dir}"
          name="com.sun.faces.el.TestValueBindingImpl_Model"/>
          <test todir="${impl.test.results.dir}

          "
          name="com.sun.faces.el.TestValueExpressionImpl_Model"/>

          M jsf-ri/systest-per-webapp/build.xml

          • systest-per-webapp tests

          + empty-string-as-null,
          + invalid-mapping,
          + converter-property-editor,

          M jsf-ri/systest/build-tests.xml

          • systests

          com/sun/faces/facelets/ImplicitFacetTestCase
          com/sun/faces/component/CompositeMetaDataTestCase

          M jsf-test/build.xml

          • regression tests

          + JAVASERVERFACES_SPEC_PUBLIC-763,
          + JAVASERVERFACES-1338,

          Ed Burns added a comment -

          M jsf-api/build.xml

          • Ignore FactoryFinder test.
          Ed Burns added a comment -

          Regarding jsf-ri/test/com/sun/faces/el/TestValueBindingImpl.java, Roger investigated this and confirmed with Kin-Man that #

          {[]}

          is a valid expression in EL 3.0, while it is an invalid expression in EL < 3.0. I'm going to simply remove that little bit of test code that uses that line from trunk and MOJARRA_2_2_0_GLASSFISH_4_0.

          Ed Burns added a comment -

          Still regarding TestValueBindingImpl.java, even after removing that little bit of test code, I still see another failure:

          [junit] Testcase: testELSet took 0.797 sec
          [junit] FAILED
          [junit] java.lang.String expected:<null> but was:<>
          [junit] junit.framework.ComparisonFailure: java.lang.String expected:<null> but was:<>
          [junit] at com.sun.faces.el.TestValueBindingImpl.testELSet(TestValueBindingImpl.java:293)

          Manfred Riem added a comment -

          com/sun/faces/component/CompositeMetaDataTestCase can be commented out since it refers to a dormant JSR.

          Manfred Riem added a comment -

          Since JAVASERVERFACES_SPEC_PUBLIC-763 is related to JSF startup we are waiting for a Weld fix that makes sure that Weld is done initializing before the ServletContextListeners are run.

          Manfred Riem added a comment - - edited

          The + invalid-mapping test is an invalid test. The JSF specification does not state /* should not be supported on a JSF configuration. Fixing the test therefor is not necessary. Note the linked issue does have a corner case that needs addressing, but that can wait until after 2.2.0.

          Manfred Riem added a comment -

          Moved to EL related tests to 2.2.1 since they are a result of a change in EL API and as such not an implementation change on our end.

          Manfred Riem added a comment -

          Fixed all the issue that are marked as sub tasks. So closing out the umbrella bug.


            People

            • Assignee:
              Unassigned
              Reporter:
              Ed Burns
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 16 hours
                16h
                Remaining:
                Time Spent - 3 hours, 45 minutes Remaining Estimate - 12 hours, 15 minutes
                12h 15m
                Logged:
                Time Spent - 3 hours, 45 minutes Remaining Estimate - 12 hours, 15 minutes
                3h 45m