javaserverfaces
  1. javaserverfaces
  2. JAVASERVERFACES-2850

Cannot set value to null for inputText in ui:repeat

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.1.20
    • Fix Version/s: 2.2.3
    • Component/s: None
    • Labels:
      None
    • Environment:

      Java 7, Tomcat 7

      Description

      When there is an inputtext inside a ui:repeat you cannot set the value of the inputtext to null, instead the old value will remain. Please see example in attached.

      It appears that null is set and then the value is overriden when the apply is called on the ui:repeat savedState.

        Issue Links

          Activity

          Manfred Riem added a comment -

          I have verified against 2.2.3 and I am unable to reproduce this.

          rogerk added a comment -

          Up priority.

          aplossystems added a comment -

          Hi sorry, I must have missed your last comment. I've now resent the file to the suggested address.

          Manfred Riem added a comment -

          Lowering priority because of no response

          Manfred Riem added a comment -

          Did you send the attachment to issues@javaserverfaces.java.net?

          rogerk added a comment -

          You need to send the attachment to: issues@javaserverfaces.java.net

          aplossystems added a comment -

          How do I attach the file?


            People

            • Assignee:
              Manfred Riem
              Reporter:
              aplossystems
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: