javaserverfaces
  1. javaserverfaces
  2. JAVASERVERFACES-2868

f:viewParam and f:viewAction not working with new taglib namespace

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0-m15
    • Fix Version/s: 2.2.1
    • Component/s: facelets
    • Labels:
      None

      Description

      I have an example with f:viewParam and f:viewAction. With the old namespace "http://java.sun.com/jsf/core" for the core taglib everything works as expected. When I switch to the new namespace "http://xmlns.jcp.org/jsf/core" neither the view param nor the view action are executed anymore.

      1. 20130618-1711-0500-i_moj_2868.patch
        184 kB
        Ed Burns
      2. changebundle.txt
        6 kB
        Ed Burns

        Issue Links

          Activity

          raupach added a comment -

          Couldn't figure out why the action method was never called and viewParam was never set. Now, I know. NetBeans 3.7.1 uses the new namespace in the editor. If you use the wizard to create a new page the new namespace is set by default. Overwrite with the old namespace and everything works as expected. This issue will cause hear tearing for a lot of people starting with Java EE 7 and NetBeans 3.7.1. Difficult to figure out why the code is not working. I would suggest raising the priority on this issue.

          Ed Burns added a comment -

          Looking at this now.

          Ed Burns added a comment -

          I can reproduce it. Working on fix now.

          Manfred Riem added a comment -

          Looks good, r=mriem

          Ed Burns added a comment -

          The fix is not yet complete. Migrating another test from the old to the new harness shows another failure. I suspect the tag library prefix migration fix missed some places. I am doing an exhaustive search now, but this will take more time.

          Ed Burns added a comment -
          • Fix issue 2868, migrate relevant tests from old harness (enhancing to
            assert correctness of fix), clean up tag migration by reducing usage
            of string literals for tag names.

          SECTION: Modified Files
          ----------------------------
          M jsf-ri/src/main/java/com/sun/faces/facelets/tag/jsf/core/CoreLibrary.java
          M jsf-ri/src/main/java/com/sun/faces/facelets/tag/jsf/html/HtmlLibrary.java
          M jsf-ri/src/main/java/com/sun/faces/facelets/tag/composite/CompositeLibrary.java
          M jsf-ri/src/main/java/com/sun/faces/facelets/tag/jstl/core/JstlCoreLibrary.java
          M jsf-ri/src/main/java/com/sun/faces/facelets/tag/ui/UILibrary.java
          M jsf-ri/src/main/java/com/sun/faces/facelets/util/FunctionLibrary.java
          M jsf-ri/src/main/java/com/sun/faces/facelets/util/DevTools.java

          • These classes are the canonical place where the constants for the
            literal strings for the tag library namespaces now live. All other
            non-JSP related callsites must use these constants instead of locally
            defined literal strings.

          The reason for not using them from JSP-related callsites is to avoid
          importing facelets-related code into JSP-related code.

          M jsf-ri/src/main/java/com/sun/faces/RIConstants.java

          • Use the new symbolic constants. The reason I didn't just fix all the
            callsites is that some of them are in JSP-related code. The reason I
            added new ones is that I thought it would be weird to have statements
            that referred to both RIConstants and the Library.Namespace
            constants.

          M jsf-ri/src/main/java/com/sun/faces/facelets/tag/jsf/CompositeComponentTagLibrary.java

          • Special care taken here. Note that the NS_*_PREFIX must have the
            trailing "/".

          M jsf-ri/src/main/java/com/sun/faces/facelets/compiler/CompilationManager.java
          M jsf-ri/src/main/java/com/sun/faces/facelets/compiler/TagUnit.java
          M jsf-ri/src/main/java/com/sun/faces/facelets/compiler/SAXCompiler.java

          • Check both namespaces. This is the heart of the bug fix.

          M jsf-ri/src/main/java/com/sun/faces/facelets/tag/jsf/core/MetadataHandler.java

          • This is a related bug fix. I was observing that the NewsReader demo
            was incorrectly displaying an error that I needed to add an f:metadata
            tag, even though I already had one. The reason was that this class
            was not setting the id of the metadata facet if it was already a
            UIPanel. The reason it was not seen in JSF 2.1 is that in JSF 2.1,
            you could only have kind of child in f:metadata. Now in JSF 2.2, you
            can have two.

          M jsf-ri/src/main/java/com/sun/faces/application/ApplicationAssociate.java

          • Use the new constants instead of string literals. Really, String
            literals are really bad. Please avoid using them.

          M jsf-test/build.xml

          • Remove reference to now-migrated test.

          M test/agnostic/facelets/pom.xml

          • call viewAction test module.

          A test/agnostic/facelets/viewAction
          A test/agnostic/facelets/viewAction/newsReader
          A test/agnostic/facelets/viewAction/newsReader/nbactions.xml
          A test/agnostic/facelets/viewAction/newsReader/src
          A test/agnostic/facelets/viewAction/newsReader/src/test
          A test/agnostic/facelets/viewAction/newsReader/src/test/java
          A test/agnostic/facelets/viewAction/newsReader/src/test/java/com
          A test/agnostic/facelets/viewAction/newsReader/src/test/java/com/sun
          A test/agnostic/facelets/viewAction/newsReader/src/test/java/com/sun/faces
          A test/agnostic/facelets/viewAction/newsReader/src/test/java/com/sun/faces/regression
          A test/agnostic/facelets/viewAction/newsReader/src/test/java/com/sun/faces/regression/i_spec_758
          A test/agnostic/facelets/viewAction/newsReader/src/test/java/com/sun/faces/regression/i_spec_758/ViewParametersIT.java
          A test/agnostic/facelets/viewAction/newsReader/src/main
          A test/agnostic/facelets/viewAction/newsReader/src/main/java
          A test/agnostic/facelets/viewAction/newsReader/src/main/java/com
          A test/agnostic/facelets/viewAction/newsReader/src/main/java/com/sun
          A test/agnostic/facelets/viewAction/newsReader/src/main/java/com/sun/faces
          A test/agnostic/facelets/viewAction/newsReader/src/main/java/com/sun/faces/regression
          A test/agnostic/facelets/viewAction/newsReader/src/main/java/com/sun/faces/regression/i_spec_758
          A test/agnostic/facelets/viewAction/newsReader/src/main/java/com/sun/faces/regression/i_spec_758/NewsReader.java
          A test/agnostic/facelets/viewAction/newsReader/src/main/java/com/sun/faces/regression/i_spec_758/NewsIndex.java
          A test/agnostic/facelets/viewAction/newsReader/src/main/java/com/sun/faces/regression/i_spec_758/NewsStory.java
          A test/agnostic/facelets/viewAction/newsReader/src/main/webapp
          A test/agnostic/facelets/viewAction/newsReader/src/main/webapp/events.xhtml
          A test/agnostic/facelets/viewAction/newsReader/src/main/webapp/template.xhtml
          A test/agnostic/facelets/viewAction/newsReader/src/main/webapp/WEB-INF
          A test/agnostic/facelets/viewAction/newsReader/src/main/webapp/WEB-INF/faces-config.xml
          A test/agnostic/facelets/viewAction/newsReader/src/main/webapp/WEB-INF/web.xml
          A test/agnostic/facelets/viewAction/newsReader/src/main/webapp/WEB-INF/glassfish-web.xml
          A test/agnostic/facelets/viewAction/newsReader/src/main/webapp/page01.xhtml
          A test/agnostic/facelets/viewAction/newsReader/src/main/webapp/page02.xhtml
          A test/agnostic/facelets/viewAction/newsReader/src/main/webapp/page03.xhtml
          A test/agnostic/facelets/viewAction/newsReader/pom.xml
          A test/agnostic/facelets/viewAction/simple
          A test/agnostic/facelets/viewAction/simple/nbactions.xml
          A test/agnostic/facelets/viewAction/simple/src
          A test/agnostic/facelets/viewAction/simple/src/test
          A test/agnostic/facelets/viewAction/simple/src/test/java
          A test/agnostic/facelets/viewAction/simple/src/test/java/com
          A test/agnostic/facelets/viewAction/simple/src/test/java/com/sun
          A test/agnostic/facelets/viewAction/simple/src/test/java/com/sun/faces
          A test/agnostic/facelets/viewAction/simple/src/test/java/com/sun/faces/test
          A test/agnostic/facelets/viewAction/simple/src/test/java/com/sun/faces/test/agnostic
          A test/agnostic/facelets/viewAction/simple/src/test/java/com/sun/faces/test/agnostic/facelets
          A test/agnostic/facelets/viewAction/simple/src/test/java/com/sun/faces/test/agnostic/facelets/viewAction
          A test/agnostic/facelets/viewAction/simple/src/test/java/com/sun/faces/test/agnostic/facelets/viewAction/simple
          A test/agnostic/facelets/viewAction/simple/src/test/java/com/sun/faces/test/agnostic/facelets/viewAction/simple/Issue758SimpleIT.java
          A test/agnostic/facelets/viewAction/simple/src/main
          A test/agnostic/facelets/viewAction/simple/src/main/java
          A test/agnostic/facelets/viewAction/simple/src/main/java/com
          A test/agnostic/facelets/viewAction/simple/src/main/java/com/sun
          A test/agnostic/facelets/viewAction/simple/src/main/java/com/sun/faces
          A test/agnostic/facelets/viewAction/simple/src/main/java/com/sun/faces/test
          A test/agnostic/facelets/viewAction/simple/src/main/java/com/sun/faces/test/agnostic
          A test/agnostic/facelets/viewAction/simple/src/main/java/com/sun/faces/test/agnostic/facelets
          A test/agnostic/facelets/viewAction/simple/src/main/java/com/sun/faces/test/agnostic/facelets/viewAction
          A test/agnostic/facelets/viewAction/simple/src/main/java/com/sun/faces/test/agnostic/facelets/viewAction/ViewActionTestBean.java
          A test/agnostic/facelets/viewAction/simple/src/main/resources
          A test/agnostic/facelets/viewAction/simple/src/main/webapp
          A test/agnostic/facelets/viewAction/simple/src/main/webapp/main.xhtml
          A test/agnostic/facelets/viewAction/simple/src/main/webapp/pageAviewActionPageA.xhtml
          A test/agnostic/facelets/viewAction/simple/src/main/webapp/main-new-namespace.xhtml
          A test/agnostic/facelets/viewAction/simple/src/main/webapp/pageAviewActionEmpty.xhtml
          A test/agnostic/facelets/viewAction/simple/src/main/webapp/pageAviewActionPageAExplicitRedirect.xhtml
          A test/agnostic/facelets/viewAction/simple/src/main/webapp/WEB-INF
          A test/agnostic/facelets/viewAction/simple/src/main/webapp/WEB-INF/faces-config.xml
          A test/agnostic/facelets/viewAction/simple/src/main/webapp/WEB-INF/web.xml
          A test/agnostic/facelets/viewAction/simple/src/main/webapp/WEB-INF/glassfish-web.xml
          A test/agnostic/facelets/viewAction/simple/src/main/webapp/result.xhtml
          A test/agnostic/facelets/viewAction/simple/src/main/webapp/pageAviewActionNull.xhtml
          A test/agnostic/facelets/viewAction/simple/pom.xml
          A test/agnostic/facelets/viewAction/pom.xml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/java
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/java/com
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/java/com/sun
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/java/com/sun/faces
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/java/com/sun/faces/regression
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/java/com/sun/faces/regression/i_spec_758_simple_war
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/java/com/sun/faces/regression/i_spec_758_simple_war/ViewActionTestBean.java
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/webapp
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/webapp/main.xhtml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/webapp/pageAviewActionPageA.xhtml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/webapp/pageAviewActionEmpty.xhtml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/webapp/pageAviewActionPageAExplicitRedirect.xhtml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/webapp/WEB-INF
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/webapp/WEB-INF/faces-config.xml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/webapp/WEB-INF/web.xml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/webapp/result.xhtml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/src/main/webapp/pageAviewActionNull.xhtml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_simple_war/pom.xml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_htmlunit
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_htmlunit/src
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_htmlunit/src/main
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_htmlunit/src/main/java
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_htmlunit/src/main/java/com
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_htmlunit/src/main/java/com/sun
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_htmlunit/src/main/java/com/sun/faces
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_htmlunit/src/main/java/com/sun/faces/regression
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_htmlunit/src/main/java/com/sun/faces/regression/i_spec_758
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_htmlunit/src/main/java/com/sun/faces/regression/i_spec_758/Issue758SimpleTestCase.java
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_htmlunit/src/main/java/com/sun/faces/regression/i_spec_758/ViewParametersTestCase.java
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_htmlunit/pom.xml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/java
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/java/com
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/java/com/sun
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/java/com/sun/faces
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/java/com/sun/faces/regression
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/java/com/sun/faces/regression/i_spec_758
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/java/com/sun/faces/regression/i_spec_758/NewsReader.java
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/java/com/sun/faces/regression/i_spec_758/NewsIndex.java
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/java/com/sun/faces/regression/i_spec_758/NewsStory.java
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/webapp
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/webapp/events.xhtml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/webapp/template.xhtml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/webapp/WEB-INF
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/webapp/WEB-INF/faces-config.xml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/webapp/WEB-INF/web.xml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/webapp/page01.xhtml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/webapp/page02.xhtml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/src/main/webapp/page03.xhtml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/i_spec_758_war/pom.xml
          D jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758/build.xml

          • Migrated test.
            Sending jsf-ri/src/main/java/com/sun/faces/RIConstants.java
            Sending jsf-ri/src/main/java/com/sun/faces/application/ApplicationAssociate.java
            Sending jsf-ri/src/main/java/com/sun/faces/facelets/compiler/CompilationManager.java
            Sending jsf-ri/src/main/java/com/sun/faces/facelets/compiler/SAXCompiler.java
            Sending jsf-ri/src/main/java/com/sun/faces/facelets/compiler/TagUnit.java
            Sending jsf-ri/src/main/java/com/sun/faces/facelets/tag/composite/CompositeLibrary.java
            Sending jsf-ri/src/main/java/com/sun/faces/facelets/tag/jsf/CompositeComponentTagLibrary.java
            Sending jsf-ri/src/main/java/com/sun/faces/facelets/tag/jsf/core/CoreLibrary.java
            Sending jsf-ri/src/main/java/com/sun/faces/facelets/tag/jsf/core/MetadataHandler.java
            Sending jsf-ri/src/main/java/com/sun/faces/facelets/tag/jsf/html/HtmlLibrary.java
            Sending jsf-ri/src/main/java/com/sun/faces/facelets/tag/jstl/core/JstlCoreLibrary.java
            Sending jsf-ri/src/main/java/com/sun/faces/facelets/tag/ui/UILibrary.java
            Sending jsf-ri/src/main/java/com/sun/faces/facelets/util/DevTools.java
            Sending jsf-ri/src/main/java/com/sun/faces/facelets/util/FunctionLibrary.java
            Deleting jsf-test/JAVASERVERFACES_SPEC_PUBLIC-758
            Sending jsf-test/build.xml
            Sending test/agnostic/facelets/pom.xml
            Adding test/agnostic/facelets/viewAction
            Adding test/agnostic/facelets/viewAction/newsReader
            Adding test/agnostic/facelets/viewAction/newsReader/nbactions.xml
            Adding test/agnostic/facelets/viewAction/newsReader/pom.xml
            Adding test/agnostic/facelets/viewAction/newsReader/src
            Adding test/agnostic/facelets/viewAction/newsReader/src/main
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/java
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/java/com
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/java/com/sun
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/java/com/sun/faces
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/java/com/sun/faces/regression
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/java/com/sun/faces/regression/i_spec_758
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/java/com/sun/faces/regression/i_spec_758/NewsIndex.java
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/java/com/sun/faces/regression/i_spec_758/NewsReader.java
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/java/com/sun/faces/regression/i_spec_758/NewsStory.java
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/webapp
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/webapp/WEB-INF
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/webapp/WEB-INF/faces-config.xml
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/webapp/WEB-INF/glassfish-web.xml
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/webapp/WEB-INF/web.xml
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/webapp/events.xhtml
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/webapp/page01.xhtml
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/webapp/page02.xhtml
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/webapp/page03.xhtml
            Adding test/agnostic/facelets/viewAction/newsReader/src/main/webapp/template.xhtml
            Adding test/agnostic/facelets/viewAction/newsReader/src/test
            Adding test/agnostic/facelets/viewAction/newsReader/src/test/java
            Adding test/agnostic/facelets/viewAction/newsReader/src/test/java/com
            Adding test/agnostic/facelets/viewAction/newsReader/src/test/java/com/sun
            Adding test/agnostic/facelets/viewAction/newsReader/src/test/java/com/sun/faces
            Adding test/agnostic/facelets/viewAction/newsReader/src/test/java/com/sun/faces/regression
            Adding test/agnostic/facelets/viewAction/newsReader/src/test/java/com/sun/faces/regression/i_spec_758
            Adding test/agnostic/facelets/viewAction/newsReader/src/test/java/com/sun/faces/regression/i_spec_758/ViewParametersIT.java
            Adding test/agnostic/facelets/viewAction/pom.xml
            Adding test/agnostic/facelets/viewAction/simple
            Adding test/agnostic/facelets/viewAction/simple/nbactions.xml
            Adding test/agnostic/facelets/viewAction/simple/pom.xml
            Adding test/agnostic/facelets/viewAction/simple/src
            Adding test/agnostic/facelets/viewAction/simple/src/main
            Adding test/agnostic/facelets/viewAction/simple/src/main/java
            Adding test/agnostic/facelets/viewAction/simple/src/main/java/com
            Adding test/agnostic/facelets/viewAction/simple/src/main/java/com/sun
            Adding test/agnostic/facelets/viewAction/simple/src/main/java/com/sun/faces
            Adding test/agnostic/facelets/viewAction/simple/src/main/java/com/sun/faces/test
            Adding test/agnostic/facelets/viewAction/simple/src/main/java/com/sun/faces/test/agnostic
            Adding test/agnostic/facelets/viewAction/simple/src/main/java/com/sun/faces/test/agnostic/facelets
            Adding test/agnostic/facelets/viewAction/simple/src/main/java/com/sun/faces/test/agnostic/facelets/viewAction
            Adding test/agnostic/facelets/viewAction/simple/src/main/java/com/sun/faces/test/agnostic/facelets/viewAction/ViewActionTestBean.java
            Adding test/agnostic/facelets/viewAction/simple/src/main/resources
            Adding test/agnostic/facelets/viewAction/simple/src/main/webapp
            Adding test/agnostic/facelets/viewAction/simple/src/main/webapp/WEB-INF
            Adding test/agnostic/facelets/viewAction/simple/src/main/webapp/WEB-INF/faces-config.xml
            Adding test/agnostic/facelets/viewAction/simple/src/main/webapp/WEB-INF/glassfish-web.xml
            Adding test/agnostic/facelets/viewAction/simple/src/main/webapp/WEB-INF/web.xml
            Adding test/agnostic/facelets/viewAction/simple/src/main/webapp/main-new-namespace.xhtml
            Adding test/agnostic/facelets/viewAction/simple/src/main/webapp/main.xhtml
            Adding test/agnostic/facelets/viewAction/simple/src/main/webapp/pageAviewActionEmpty.xhtml
            Adding test/agnostic/facelets/viewAction/simple/src/main/webapp/pageAviewActionNull.xhtml
            Adding test/agnostic/facelets/viewAction/simple/src/main/webapp/pageAviewActionPageA.xhtml
            Adding test/agnostic/facelets/viewAction/simple/src/main/webapp/pageAviewActionPageAExplicitRedirect.xhtml
            Adding test/agnostic/facelets/viewAction/simple/src/main/webapp/result.xhtml
            Adding test/agnostic/facelets/viewAction/simple/src/test
            Adding test/agnostic/facelets/viewAction/simple/src/test/java
            Adding test/agnostic/facelets/viewAction/simple/src/test/java/com
            Adding test/agnostic/facelets/viewAction/simple/src/test/java/com/sun
            Adding test/agnostic/facelets/viewAction/simple/src/test/java/com/sun/faces
            Adding test/agnostic/facelets/viewAction/simple/src/test/java/com/sun/faces/test
            Adding test/agnostic/facelets/viewAction/simple/src/test/java/com/sun/faces/test/agnostic
            Adding test/agnostic/facelets/viewAction/simple/src/test/java/com/sun/faces/test/agnostic/facelets
            Adding test/agnostic/facelets/viewAction/simple/src/test/java/com/sun/faces/test/agnostic/facelets/viewAction
            Adding test/agnostic/facelets/viewAction/simple/src/test/java/com/sun/faces/test/agnostic/facelets/viewAction/simple
            Adding test/agnostic/facelets/viewAction/simple/src/test/java/com/sun/faces/test/agnostic/facelets/viewAction/simple/Issue758SimpleIT.java
            Transmitting file data .............................................
            Committed revision 12012.
          Ed Burns added a comment -

          Job 32 failed because I miscounted the passed.test.count decrement. It should have gone down by five instead of two. It will pass next time with the correctly decremented count.

          The other jobs passed. I'm calling this clean.


            People

            • Assignee:
              Ed Burns
              Reporter:
              michael_kurz
            • Votes:
              3 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 4 hours, 41 minutes
                4h 41m