Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 2.2.5
    • Component/s: expression language
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      896
    • Status Whiteboard:

      size_medium importance_small

      Show
      size_medium importance_small

      Description

      It looks like a failed stylesheet rendering(point it to a non existing css) disrupts the postback of my form data.

      <h:outputStylesheet library="test" name="style.css" />

      Form:
      <h:form>
      <h:inputText value="#

      {testBean.selectedRow.name}" required="true" />
      </h:form>

      Stylesheet warning:
      WARNING javax.enterprise.resource.webcontainer.jsf.application JSF1064: Unable to find or serve resource, style.css, from library,
      test.

      Error:
      javax.el.PropertyNotFoundException: /test.xhtml @47,100 value="#{testBean.selectedRow.name}

      ": Target Unreachable, 'null' returned null
      at com.sun.faces.facelets.el.TagValueExpression.getType(TagValueExpression.java:97)
      at com.sun.faces.renderkit.html_basic.HtmlBasicInputRenderer.getConvertedValue(HtmlBasicInputRenderer.java:91)
      at javax.faces.component.UIInput.getConvertedValue(UIInput.java:1023)
      at javax.faces.component.UIInput.validate(UIInput.java:953)
      at javax.faces.component.UIInput.executeValidate(UIInput.java:1204)
      at javax.faces.component.UIInput.processValidators(UIInput.java:693)
      at javax.faces.component.UIComponentBase.processValidators(UIComponentBase.java:1081)
      at javax.faces.component.UIForm.processValidators(UIForm.java:240)
      at javax.faces.component.UIComponentBase.processValidators(UIComponentBase.java:1081)
      at javax.faces.component.UIComponentBase.processValidators(UIComponentBase.java:1081)
      at javax.faces.component.UIViewRoot.processValidators(UIViewRoot.java:1159)
      at com.sun.faces.lifecycle.ProcessValidationsPhase.execute(ProcessValidationsPhase.java:72)
      at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:97)
      at com.sun.faces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:114)
      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:308)
      at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1523)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:279)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:188)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:641)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:97)
      at com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPipeline.java:85)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:185)
      at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:325)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:226)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:165)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:791)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:693)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:954)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:170)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:135)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:102)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:88)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:76)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:53)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:57)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:69)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:330)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:309)
      at java.lang.Thread.run(Thread.java:619)

        Activity

        marksm1977 added a comment -

        Btw if you want to reproduce the issue just take the virtual trainer app example
        and change the css definition in the template.xhtml. This will break the
        EditTraningEvent.xhtml

        rogerk added a comment -

        triage

        rogerk added a comment -

        triage

        Ed Burns added a comment -

        Moved from JAVASERVERFACES_SPEC_PUBLIC JIRA.

        Manfred Riem added a comment -

        Closing this issue as I am unable to reproduce this.


          People

          • Assignee:
            Manfred Riem
            Reporter:
            marksm1977
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: