javaserverfaces
  1. javaserverfaces
  2. JAVASERVERFACES-3205

Postback executes <f:event type="preRenderView"> listeners of another view when current view contains h:link which uses includeViewParams

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.25, 2.1.28, 2.2.5
    • Fix Version/s: 2.2.7
    • Labels:
      None
    • Environment:

      Windows 7 64-bit, Jetty

      Description

      When creating a link with an outcome that resolves to a page and using the includeViewParams, the preRenderView event of the target page will be attached to the current viewroot during the first render phase.
      On any postback of the first page, the preRenderView listener of the target page will be executed on the preRenderView event trigger of the first page. Even if the postback has nothing to do with the target page.
      In our case, the preRenderView event is used to check if the viewParams have a correct value, and an exception is thrown on any postback of the first page.

      See also https://java.net/jira/browse/JAVASERVERFACES-2158

      Attached is an example of 2 pages with 2 beans showing the issue. The first.xhtml page contains a bit of an explanation of how the problem is triggered.
      I conducted extra tests against the most recent versions of JSF 2.1 and 2.2

      It doesn't matter if you use an outcome defined in a NavigationCase in faces-config or just the name of the target view as outcome.

        Issue Links

          Activity

          Manfred Riem added a comment -

          Can you please send the reproducer zip to issues@javaserverfaces.java.net? Thanks!

          Ed Burns added a comment -

          Must revert, fails these two tests:

          com.sun.faces.test.agnostic.facelets.core.Issue2260IT.testViewParamPassing
          com.sun.faces.test.agnostic.facelets.core.Issue2718IT.testDefaultStateless

          Ed Burns added a comment -

          SECTION: Modified Files
          ----------------------------
          M jsf-ri/src/main/java/com/sun/faces/application/view/ViewMetadataImpl.java
          M test/agnostic/facelets/core/src/test/java/com/sun/faces/test/agnostic/facelets/core/Issue3205IT.java

          • Revert fix pending investigation of these failures:

          com.sun.faces.test.agnostic.facelets.core.Issue2260IT.testViewParamPassing
          com.sun.faces.test.agnostic.facelets.core.Issue2718IT.testDefaultStateless
          Sending jsf-ri/src/main/java/com/sun/faces/application/view/ViewMetadataImpl.java
          Sending test/agnostic/facelets/core/src/test/java/com/sun/faces/test/agnostic/facelets/core/Issue3205IT.java
          Transmitting file data ..
          Committed revision 13095.

          Ed Burns added a comment -

          Committed to 2.2.x

          SECTION: Modified Files
          ----------------------------
          M jsf-ri/src/main/java/com/sun/faces/application/view/ViewMetadataImpl.java
          M test/agnostic/facelets/core/src/test/java/com/sun/faces/test/agnostic/facelets/core/Issue3205IT.java

          • Have to back this out again due to test failure.
            Sending jsf-ri/src/main/java/com/sun/faces/application/view/ViewMetadataImpl.java
            Sending test/agnostic/facelets/core/src/test/java/com/sun/faces/test/agnostic/facelets/core/Issue3205IT.java
            Transmitting file data ..
            Committed revision 13117.
          Ed Burns added a comment -

          Committed to 2.2.x

          SECTION: Modified Files
          ----------------------------
          M jsf-ri/src/main/java/com/sun/faces/application/view/ViewMetadataImpl.java
          M test/agnostic/facelets/core/src/test/java/com/sun/faces/test/agnostic/facelets/core/Issue3205IT.java

          • Have to back this out again due to test failure.
            Sending jsf-ri/src/main/java/com/sun/faces/application/view/ViewMetadataImpl.java
            Transmitting file data .
            Committed revision 13118.
          Ed Burns added a comment -

          All required jobs are clean.


            People

            • Assignee:
              Ed Burns
              Reporter:
              Ben.Winkeler
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 5 hours, 1 minute
                5h 1m