javaserverfaces-spec-public
  1. javaserverfaces-spec-public
  2. JAVASERVERFACES_SPEC_PUBLIC-1148

Ability to use JSF Engine to render emails - "one way to do things"

    Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Require to use JSF to render emails from an "email" page template ; possibly fired from a EJB timer (so no client).

      Basically to get JSF email rendering working consistently, we need to be able to boot an embedded version of JSF that has full programmatic control. This requires a number things such as splitting out the core engine so it has no servlet dependencies, ensuring that there is no thread dependence in the core etc.

      Note; gmail (and others) only work with embedded styles I believe.

      Seam2 had this capability (to some respect)

      Originally raised: JAVASERVERFACES-2615 (http://java.net/jira/browse/JAVASERVERFACES-2615?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=350860#action_350860)
      Ed asked for it to be raised here.

        Issue Links

          Activity

          kithouna added a comment -

          Isn't this a duplicate of JAVASERVERFACES_SPEC_PUBLIC-749?

          tony.herstell added a comment -

          Craig (see this site) is working on a JSF Mail plugin...
          http://reallifejava.com/blog/

          As well as Seamy stuff like
          simpleBPM
          simpleSecuirty

          Think:
          s/simeple/seam4/g

          No promises though.

          Ed Burns added a comment -

          Set priority to baseline ahead of JSF 2.3 triage. Priorities will be assigned accurately after this exercise.


            People

            • Assignee:
              Unassigned
              Reporter:
              tony.herstell
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: