javaserverfaces-spec-public
  1. javaserverfaces-spec-public
  2. JAVASERVERFACES_SPEC_PUBLIC-1186

Many component from HTML namespace are missing 'role' attributes

    Details

      Description

      Components of the "http://xmlns.jcp.org/jsf/html" namespace are missing attributes like 'role':
      h:body, h:dataTable, h:form, h:graphicImage, h:inputSecret, h:inputSecret, h:inputTextarea, h:message, h:messages, h:outputFormat, h:outputLabel, h:outputLink, h:outputScript, h:outputStylesheet, h:outputText, h:panelGrid, h:selectBooleanCheckbox, h:selectManyCheckbox, h:selectManyListbox, h:selectManyMenu, h:selectOneListbox, h:selectOneMenu, h:selectOneRadio

      I know that you are pretty close to the FCS, probably not necessary for the final build. Fixing it into the next dot release/patch would be really appreciated.

      See related NetBeans issue: https://netbeans.org/bugzilla/show_bug.cgi?id=228286

        Activity

        marfous created issue -
        Ed Burns made changes -
        Field Original Value New Value
        Project javaserverfaces [ 10204 ] javaserverfaces-spec-public [ 10222 ]
        Key JAVASERVERFACES-2856 JAVASERVERFACES_SPEC_PUBLIC-1186
        Affects Version/s 2.2 [ 10403 ]
        Affects Version/s 2.2.0-m14 [ 16146 ]
        Component/s Documentation: Javadoc, TLDDoc, RenderkitDoc, PDF [ 10224 ]
        Component/s resources [ 10549 ]
        marfous added a comment -

        I think that vdldocs define it correctly, the issue is that it's not defined in the metadata of the JSF library.

        marfous added a comment -

        I'm attaching patch for fixing this definition issue of the html_basic.taglib.xml metadata:
        https://dl.dropboxusercontent.com/u/1418580/JAVASERVERFACES_SPEC_PUBLIC-1186.patch

        Thanks in advance.

        Ed Burns added a comment -

        Sorry this took so long, especially considering the triviality of doing it.

        Ed Burns made changes -
        Assignee Ed Burns [ edburns ]
        Ed Burns made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Ed Burns added a comment -

        SECTION: Modified Files
        ----------------------------
        M jsf-ri/conf/share/html_basic.taglib.xml

        • From Martin Fousek. Add role attribute to taglib.xml for HTML_BASIC.
          Sending jsf-ri/conf/share/html_basic.taglib.xml
          Transmitting file data .
          Committed revision 12454.
        Ed Burns made changes -
        Status In Progress [ 3 ] Closed [ 6 ]
        Fix Version/s 2.3 [ 16372 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            Ed Burns
            Reporter:
            marfous
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: