javaserverfaces-spec-public
  1. javaserverfaces-spec-public
  2. JAVASERVERFACES_SPEC_PUBLIC-1228

Consider UIInputFile as a means to deal with the problem of the "value" attribute with respect to state saving.

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Components/Renderers
    • Labels:
      None

      Description

      JSF 2.2 added file upload but did so by leveraging the javax.faces.Input component-family with the newly-defined javax.faces.File renderer-type. There is one aspect in which this may be problematic: the storing of the "value" property in component state. Please see JAVASERVERFACES-3037.

        Issue Links

          Activity

          Ed Burns added a comment -

          Set priority to baseline ahead of JSF 2.3 triage. Priorities will be assigned accurately after this exercise.

          Ed Burns added a comment -

          Impl issue marked as Cannot Reproduce.


            People

            • Assignee:
              Unassigned
              Reporter:
              Ed Burns
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 4 days
                4d
                Remaining:
                Remaining Estimate - 4 days
                4d
                Logged:
                Time Spent - Not Specified
                Not Specified