Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.2
    • Component/s: Uncategorized
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      193

      Description

      Chapter 3.1.1 is as follows:
      >
      Every component may be named by a component identifier, which (if utilized) must
      be unique among the components that share a common naming container parent in a
      component tree. Component identifiers must conform to the following rules:
      â–  They must start with a letter (as defined by the Character.isLetter() method).
      â–  Subsequent characters may be letters (as defined by the
      Character.isLetter() method), digits as defined by the Character.isDigit()
      method, dashes (‘-’), and underscores (‘_’).
      To minimize the size of responses generated by JavaServer Faces, it is
      recommended that component identifiers be as short as possible.
      If a component has been given an identifier, it must be unique in the namespace
      of the closest ancestor to that component that is a NamingContainer (if any).

      -------------------------------------------------------------------------

      I think we'll consolidate the verbage about id uniqueness in a namingcontainer
      as a bullit item for the rules.

        Activity

        rogerk added a comment -
            • Issue 194 has been marked as a duplicate of this issue. ***
        rogerk added a comment -

        Sec edits complete.

        Ed Burns added a comment -

        Prepare to delete "spec" subcomponent.

        Ed Burns added a comment -

        Move all to 1.2

        Manfred Riem added a comment -

        Closing resolved issue out


          People

          • Assignee:
            rogerk
            Reporter:
            rogerk
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: