Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2 Sprint 8
    • Fix Version/s: 1.2
    • Component/s: Uncategorized
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      211

      Description

      I would like to see an enhancement to the spec where the Faces ELResolver
      exposes the UIComponent that is currently being processed as an implicit object.
      This would mean:

      • Any expressions bound to a component could refer to the current component.
      • Any conversion and validation logic could refer to the current component
        (making it more practical to use "java.beans.PropertyEditor"s as converters for
        example).
      • Many cases where the "binding" attribute is now used would be simplified.

        Issue Links

          Activity

          Ed Burns added a comment -
              • Issue 278 has been marked as a duplicate of this issue. ***
          Ed Burns added a comment -

          blocks 272

          Ed Burns added a comment -

          Fixed.

          Ed Burns added a comment -

          Prepare to delete "spec" subcomponent.

          Ed Burns added a comment -

          Move all to 1.2

          Manfred Riem added a comment -

          Closing resolved issue out


            People

            • Assignee:
              Ed Burns
              Reporter:
              tony_robertson
            • Votes:
              2 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: