Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.0
    • Fix Version/s: 1.2
    • Component/s: Uncategorized
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Macintosh

    • Issuezilla Id:
      252

      Description

      When working on a project to allow JSF artifacts to be written in JavaScript, I
      came to the point to handle validators. Validators are stateful in that they
      are attached to components, which are themselves stateful. Therefore,
      validators implement StateHolder. I had to wrap my JavaScript implemented
      validator in a java class that implements StateHolder. I'd rather not have to
      do that.

        Issue Links

          Activity

          Ed Burns added a comment -

          Remove block of 273

          driscoll added a comment -

          Per Ed, closed as a duplicate of 139.

              • This issue has been marked as a duplicate of 139 ***
          Ed Burns added a comment -

          Per 20080820 EG meeting, I am taking action on these issues.

          Ed Burns added a comment -

          Per 20080820 EG meeting, marking these as WONTFIX. In some cases, this means the issue was fixed
          already, under another issue. In other cases, this means the issue is too vague to fix. In still other cases,
          this means the EG deemed that the issue isn't appropriate for fixing.

          If you strongly disagree with this resolution, please contact jsr-314-comments@jcp.org.

          Ed Burns added a comment -

          Prepare to delete "spec" subcomponent.

          Ed Burns added a comment -

          Move all to 1.2

          Manfred Riem added a comment -

          Closing resolved issue out


            People

            • Assignee:
              Ed Burns
              Reporter:
              Ed Burns
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: