Issue Details (XML | Word | Printable)

Key: JAVASERVERFACES_SPEC_PUBLIC-334
Type: Bug Bug
Status: Resolved Resolved
Resolution: Duplicate
Priority: Major Major
Assignee: javaserverfowner
Reporter: mfreedma
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
javaserverfaces-spec-public

Portlet Bridge Issue: Support all extensions running at same level

Created: 05/Mar/08 01:07 PM   Updated: 25/Nov/10 06:43 PM   Resolved: 24/Nov/09 07:48 AM
Component/s: Uncategorized
Affects Version/s: 2.0
Fix Version/s: 2.0

Time Tracking:
Not Specified

Environment:

Operating System: All
Platform: All

Issue Links:
Dependency
 

Issuezilla Id: 334
Status Whiteboard:

EGTop5 effort_hard

Tags:
Participants: Ed Burns, javaserverfowner, mfreedma and rogerk


 Description  « Hide

Background: Because the base Faces implementation contains servlet dependencies
and/or is only implemented to support the servlet model the bridge ends up being
a replacement/alternative base when run in the portlet environment. The bridge
uses the various Faces extension points to plug itself in to override this base
behavior. In general its preferrable if the bridge's extensions were always at
the bottom of the stack, closest to the base. This can me somewhat accomplished
with the FacesContext/ExternalContext by defining the FacesContextFactory as a
service and asking all other Faces extensions to define their
FacesContextFactory in the face-config.xml. However there are numerous bridge
extensions that can only be defined in the faces-config.xml (ViewHandler,
StateManager, ELResolver). Some implementation in these extensions are
complicated by the bridge having to assume it may be prematurely called (i.e.
extensions would be called after it if it delegated) vs. delegation would be
inappropriate because those impls being covered are base/servlet dependent
impls. Its also a little weird to have part of the bridge inserted into the
Faces structure at a low level and the rest of it at a more random upper level.

Need: A way to control order that extensions are configured/executed in Faces.



rogerk added a comment - 22/Aug/08 08:51 AM

Status Whiteboard


Ed Burns added a comment - 12/Sep/08 04:31 PM

effort_hard


Ed Burns added a comment - 12/Sep/08 04:47 PM

change target_milestone to 2.0


Ed Burns added a comment - 20/Oct/08 01:01 PM

Depends on 121


Ed Burns added a comment - 21/Oct/08 01:40 PM

Subsumed by 121

      • This issue has been marked as a duplicate of 121 ***

Ed Burns added a comment - 24/Nov/09 07:48 AM

Prepare to delete "spec" subcomponent.