javaserverfaces-spec-public
  1. javaserverfaces-spec-public
  2. JAVASERVERFACES_SPEC_PUBLIC-359

PortletBridge issue: Allow EL expression in <to-view-id> of nav rule

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Uncategorized
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      359
    • Status Whiteboard:

      EGTop5 effort_hard

      Show
      EGTop5 effort_hard

      Description

      The portlet model's mechanism for switching views is based on a concept called
      portlet Modes. A portlet has distinct Modes (View, Edit, Help). A portlet
      typically renders a different view/from a different view context depending on a
      mode. Within a given Mode a portlet can extend the model and manage a current
      view from within a set of views (for that Mode).

      I.e. rather then a typical JSF application having a single set of views that
      compose the application, a JSF portlet application has N sets of views where N
      is the number of modes supported by the portlet.

      Typically when a portlet enters a Mode (from View Mode) they enter at the Modes
      default view. However when they exit the Mode by returning to the prior Mode
      they just as commonly want to return to the view that was current when they left
      the mode as they want to return to that Mode's default view. The portlet
      developer is responsible for encoding this navigation directly – though the
      underlying environment typically supports navigating to the default view in the
      situation that the portlet does nothing other than switch Modes.

      The Portlet bridge wants to make it possible for a JSF application to encode
      this information in a navigation (rule). It is considering doing the following:

      retaining the lastViewId of a Mode being exited and making it available on a
      request Attribute (e.g. the request attribute:
      javax.portlet.faces.currentViewId.VIEW would have a value of the viewId of the
      last view in the last view that was in the portlet VIEW mode. If you wanted the
      last mode of the EDIT mode it would be accessed similarly:
      javax.portlet.faces.currentViewId.EDIT)

      By doing this one could now write the following EL to reference this view:
      #

      {requestScope["javax.portlet.faces.currentViewId.VIEW"]}

      To make this useful however, the developer needs to be able to specify this in
      the <to-view-id> element of their navigation rule. I.e. Because the portlet use
      cases demands that the developer dynamically determine the navigation view when
      it triggers/encodes a mode change we would like JSF to support expressing such
      dynanism in its navigation rules. As JSF current doesn't specify that the
      <to-view-id> element contains/evaluates an EL expression we are seeking this change.

        Issue Links

          Activity

          Ed Burns added a comment -
              • Issue 325 has been marked as a duplicate of this issue. ***
          rogerk added a comment -

          Status Whiteboard

          Ed Burns added a comment -

          effort_hard

          Ed Burns added a comment -

          change target_milestone to 2.0

          Ed Burns added a comment -

          to Ryan

          Ed Burns added a comment -

          Fixed

          Ed Burns added a comment -

          Prepare to delete "spec" subcomponent.

          Manfred Riem added a comment -

          Closing resolved issue out


            People

            • Assignee:
              Ryan Lubke
              Reporter:
              mfreedma
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: