javaserverfaces-spec-public
  1. javaserverfaces-spec-public
  2. JAVASERVERFACES_SPEC_PUBLIC-414

ConverterException from BindingValidator, when there is no #{blahblah} validator bean present

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.2
    • Fix Version/s: 1.2
    • Component/s: Uncategorized
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      414

      Description

      do something like:

      <f:validator binding="#

      {yadayadayada}"/>

      and get this stack trace:

      javax.faces.convert.ConverterException: Unable to resolve a Validator
      instance using either validatorId '' or binding '#{yadayadayada}

      '.
      at
      com.sun.faces.taglib.jsf_core.ValidatorTag$BindingValidator.validate(ValidatorTag.java:168)
      at
      org.apache.myfaces.trinidad.component.UIXEditableValue.validateValue(UIXEditableValue.java:345)
      at
      org.apache.myfaces.trinidad.component.UIXEditableValue.validate(UIXEditableValue.java:172)
      at
      org.apache.myfaces.trinidad.component.UIXEditableValue._executeValidate(UIXEditableValue.java:488)
      at
      org.apache.myfaces.trinidad.component.UIXEditableValue.processValidators(UIXEditableValue.java:270)
      at
      org.apache.myfaces.trinidad.component.UIXComponentBase.validateChildrenImpl(UIXComponentBase.java:1005)
      at
      org.apache.myfaces.trinidad.component.UIXComponentBase.validateChildren(UIXComponentBase.java:990)
      at
      org.apache.myfaces.trinidad.component.UIXComponentBase.processValidators(UIXComponentBase.java:828)
      at
      org.apache.myfaces.trinidad.component.UIXComponentBase.validateChildrenImpl(UIXComponentBase.java:1005)
      at
      org.apache.myfaces.trinidad.component.UIXComponentBase.validateChildren(UIXComponentBase.java:990)

        Activity

        Ryan Lubke added a comment -

        This is an implementation issue (775).

        Ed Burns added a comment -

        Per 20080820 EG meeting, I am taking action on these issues.

        Ed Burns added a comment -

        Per 20080820 EG meeting, marking these as WONTFIX. In some cases, this means the issue was fixed
        already, under another issue. In other cases, this means the issue is too vague to fix. In still other cases,
        this means the EG deemed that the issue isn't appropriate for fixing.

        If you strongly disagree with this resolution, please contact jsr-314-comments@jcp.org.

        Ed Burns added a comment -

        Prepare to delete "implementation" subcomponent.

        Ed Burns added a comment -

        Move all to 1.2

        Manfred Riem added a comment -

        Closing resolved issue out


          People

          • Assignee:
            javaserverfowner
            Reporter:
            mwessendorf
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: