Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 2.0
    • Component/s: Uncategorized
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      428
    • Status Whiteboard:

      EGTop5 effort_moderate

      Show
      EGTop5 effort_moderate

      Description

      Let's say we have a input secret component in a view.
      To this component we have associated a custom validator and a value
      change listener
      <h:inputSecret>
      <f:valueChangeListener
      type="test.ValueChangeListener" />
      <f:validator validatorId="test.CustomValidator"
      />
      </h:inputSecret>

      On postback request without having anything submitted as a value, we
      have the VCL executed but not the validator.
      Actually in UIInput a custom validator is only invoked when the newValue
      is not empty.
      Again we have a VCE queued because the compareValues returns true when
      the previous value is "" and new is null.
      From spec point of view if we have a VCE queued than we could expect
      that the validatior is also invoked.

      Now this situation has another aspect.
      From UIInput component point of view when we have a value transition
      from null to "" that should be enough for firing VCE AND invoking a
      validator. UIInput is a generic protocol independent component and it
      seems logical to have this behavior there.

      From html, http perspective however we don't have the same notion. The
      semantics of "" and null is the same. And that leads to the
      inconsistency of having VCL invoked but not a validator.

        Issue Links

          Activity

          Ryan Lubke added a comment -

          CC'ing Roger.

          Ed Burns added a comment -
              • Issue 181 has been marked as a duplicate of this issue. ***
          pmuir added a comment -

          N.B. https://javaserverfaces-spec-public.dev.java.net/issues/show_bug.cgi?id=181
          is requesting the deprecation of required="true" in favour of applying a proper
          validator. This is also required for
          https://javaserverfaces-spec-public.dev.java.net/issues/show_bug.cgi?id=426 -
          Bean Validation

          pmuir added a comment -

          Needs fixing in EL

          Ed Burns added a comment -

          Change target milestone to 2.0

          Ed Burns added a comment -

          I assert this is fixed with the EMPTY_STRING_VALUE_AS_NULL context param

          Ed Burns added a comment -

          Fixed

          Ed Burns added a comment -

          Prepare to delete "spec" subcomponent.

          Manfred Riem added a comment -

          Closing resolved issue out


            People

            • Assignee:
              Ed Burns
              Reporter:
              Ryan Lubke
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: