Issue Details (XML | Word | Printable)

Key: JAVASERVERFACES_SPEC_PUBLIC-498
Type: Improvement Improvement
Status: Resolved Resolved
Resolution: Duplicate
Priority: Blocker Blocker
Assignee: javaserverfowner
Reporter: cdoremus
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
javaserverfaces-spec-public

Upgrade Standard HTML RenderKit to XHTML

Created: 18/Oct/08 06:44 PM   Updated: 08/Jun/10 02:16 PM   Resolved: 08/Jun/10 02:16 PM
Component/s: Components/Renderers
Affects Version/s: 2.0
Fix Version/s: 2.1

Time Tracking:
Not Specified

Environment:

Operating System: All
Platform: All


Issuezilla Id: 498
Status Whiteboard:

cat2 renderkit

Tags:
Participants: cdoremus, Ed Burns, javaserverfowner and lincolnbaxter


 Description  « Hide

Although JSF 2.0 will support facelets it is suprising that the current draft of
the spec still specifies the Standard HTML RenderKit to use HTML 4.01. I suggest
that the RenderKit specification be upgraded to XHTML compliance since the
facelets UI is done in XHTML. This will also allow JSF to support the WAP 2
standard since it specifies a subset of XHTML.



Ed Burns added a comment - 24/Sep/09 09:13 AM

Move to unscheduled target milestone


Ed Burns added a comment - 24/Nov/09 07:48 AM

Prepare to delete "spec" subcomponent.


lincolnbaxter added a comment - 26/Jan/10 01:02 PM

Categorized as part of Rev 2.0 A prep


Ed Burns added a comment - 04/Mar/10 12:31 PM

We've talked about this issue on the EG. Dan was more in favor of dropping the claim of XHTML
support instead of just saying XML. I'm not sure yet. This also ties in with HTML5 issues.


Ed Burns added a comment - 22/Mar/10 11:37 AM

renderkit


Ed Burns added a comment - 15/May/10 07:54 AM

These are targeted at 2.1.


Ed Burns added a comment - 08/Jun/10 02:16 PM

Fold into 697

      • This issue has been marked as a duplicate of 697 ***