Issue Details (XML | Word | Printable)

Key: JAVASERVERFACES_SPEC_PUBLIC-774
Type: Improvement Improvement
Status: Resolved Resolved
Resolution: Won't Fix
Priority: Major Major
Assignee: Unassigned
Reporter: werpu12
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
javaserverfaces-spec-public

Request for enhancement: Dynamic configuration changes

Created: 19/Mar/10 07:20 AM   Updated: 19/Dec/13 11:00 PM   Resolved: 19/Dec/13 11:00 PM
Component/s: Uncategorized
Affects Version/s: 2.1
Fix Version/s: 2.2

Time Tracking:
Not Specified

Environment:

Operating System: All
Platform: Macintosh
URL: http://people.apache.org/~werpu/Proposal%20Configuration.pdf


Issuezilla Id: 774
Status Whiteboard:

size_large importance_large draft

Tags:
Participants: Ed Burns and werpu12


 Description  « Hide

As of now the JSF configuration is static with limited possibility to alter it
from the scope of an extension framework or application. This (see url included)
tries to fix this problem by introducing a central configuration singleton
object which allows read and write access on the configuration and a set of
system events which are used to allow implementations and extension frameworks
to perform the necessary steps upon the configuration change request.

Below is the link to the proposal from my side which should give an initial
start to the discussion.

http://people.apache.org/~werpu/Proposal%20Configuration.pdf



werpu12 added a comment - 19/Mar/10 07:21 AM

changed rev to 2.1


Ed Burns added a comment - 24/Mar/10 01:50 PM
      • Issue 241 has been marked as a duplicate of this issue. ***

Ed Burns added a comment - 24/Mar/10 01:51 PM

From issue 241

AJ> I would like to see a MBean to query an applications runtime setup
AJ> (in relation to JSF). Basically this would be read-only.

AJ> Exception: ManagedBean-Attributes. The configured attributes of a
AJ> managed bean with scope application should be editable. this would
AJ> allow to have some control-values in managed beans and be able to
AJ> control it in a standard way and access it in an easy way in the
AJ> views.


Ed Burns added a comment - 08/Jun/10 01:05 PM

triage


Ed Burns added a comment - 22/Jun/10 09:02 PM

edburns


Ed Burns added a comment - 24/Jun/10 02:41 PM

GlassFish 3.1 M6 at the latest.


Ed Burns added a comment - 10/Sep/10 01:31 PM

Move these to 2.2


kenaiadmin made changes - 25/Nov/10 06:44 PM
Field Original Value New Value
issue.field.bugzillaimportkey 774 20379
Ed Burns made changes - 31/Jan/11 07:48 AM
Status Whiteboard size_large importance_large size_large importance_large draft
Ed Burns made changes - 08/Nov/13 09:15 PM
Assignee Ed Burns [ edburns ]
Ed Burns added a comment - 19/Dec/13 11:00 PM

This sort of thing might be the domain of the new Configuration JSR, tentatively lead by Antatole Tesch of Credit Suisse.


Ed Burns made changes - 19/Dec/13 11:00 PM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Won't Fix [ 2 ]