Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0
    • Fix Version/s: 2.2
    • Component/s: Facelets/VDL
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Macintosh

    • Issuezilla Id:
      791
    • Status Whiteboard:

      cat1 size_small importance_large

      Show
      cat1 size_small importance_large

      Description

      There is a <composite:clientBehavior> tag in the 2.0 version of JSF that comes
      with GlassFish, and it appears to work as advertised by Alexandr and Andy below.

      But, as Alexandr points out, it’s not documented in the PDL docs, nor could I
      find any mention of it in the spec (or Ed’s book, either).

      This is a vital tag that lets page authors attach ajax functionality to
      components within composite components. I see no reason why it should not be
      documented.

      Does anyone know why this tag was not documented in the first place, or what the
      plans are for its future? Anyone know if it works with MyFaces 2.0?

      If there’s not a compelling reason for blacklisting it from the docs, can we
      document it?

      Thanks,

      david

        Activity

        Ed Burns added a comment -

        GlassFish 3.1 M6 at the latest.

        Ed Burns added a comment -

        Move these to M5

        Ed Burns added a comment -

        Move these to 2.2

        Ed Burns added a comment -

        Duplicate of issue 853

            • This issue has been marked as a duplicate of 853 ***
        Manfred Riem added a comment -

        Closing resolved issue out


          People

          • Assignee:
            Ed Burns
            Reporter:
            rogerk
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: