Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2 Sprint 8
    • Fix Version/s: 2.2
    • Component/s: Facelets/VDL
    • Labels:
      None
    • Status Whiteboard:

      size_medium importance_medium

      Show
      size_medium importance_medium

      Description

      A @ViewScoped bean will behave like a @RequestScoped bean when JSTL c:forEach or
      c:if tag is been used in the view. I.e. it will be recreated on every request.

      I can't find any line in the JSF specification if this is intentional or not.

        Activity

        Hanspeter Duennenberger added a comment -
        dwightd added a comment -

        This problem appears to be fixed in 2.1.18, at least in my environment (with ICEfaces 3.2). It was still broken in 2.1.17. Looking over the fixes in 2.1.18, it might be that http://java.net/jira/browse/JAVASERVERFACES-2688 fixed it, although I'm guessing somewhat. (I have a limited understanding of the cause and possible fixes!)

        This also seems related to http://java.net/jira/browse/JAVASERVERFACES-1492


          People

          • Assignee:
            Ed Burns
            Reporter:
            rogerk
          • Votes:
            7 Vote for this issue
            Watchers:
            9 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: