jawr
  1. jawr
  2. JAWR-244

NullPointerException in logs JAWRRequestHandler

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 3.3.3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Linux, IBM Websphere 8, development env

      Description

      We are seeing the below exception intermittently in our SystemOut logs.
      Typically we see this exception when a web request is made after a long time(i.e. no requests are made for a long period- say 8 hours).
      There is no effect to the front end i.e. we donot see any errors in the web pages.
      we have jawr debug on in the env. We are not sure if this exception will have any implications in the prod environment. Hence wanted to make sure if this is something that needs to be fixed?
      Stack trace
      [3/12/13 11:25:24:635 EDT] 00000033 servlet E com.ibm.ws.webcontainer.servlet.ServletWrapper service SRVE0014E: Uncaught service() exception root cause JavascriptServlet: javax.servlet.ServletException
      : java.lang.NullPointerException
      at net.jawr.web.servlet.JawrRequestHandler.doGet(JawrRequestHandler.java:455)
      at net.jawr.web.servlet.JawrServlet.doGet(JawrServlet.java:76)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:575)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:668)
      at com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.java:1214)
      at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:774)
      at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:456)
      at com.ibm.ws.webcontainer.servlet.ServletWrapperImpl.handleRequest(ServletWrapperImpl.java:178)
      at com.ibm.ws.webcontainer.filter.WebAppFilterChain.invokeTarget(WebAppFilterChain.java:125)
      at com.ibm.ws.webcontainer.filter.WebAppFilterChain.doFilter(WebAppFilterChain.java:77)
      at com.ibm.ws.webcontainer.filter.WebAppFilterManager.doFilter(WebAppFilterManager.java:926)
      at com.ibm.ws.webcontainer.filter.WebAppFilterManager.invokeFilters(WebAppFilterManager.java:1023)
      at com.ibm.ws.webcontainer.servlet.CacheServletWrapper.handleRequest(CacheServletWrapper.java:87)
      at com.ibm.ws.webcontainer.WebContainer.handleRequest(WebContainer.java:895)
      at com.ibm.ws.webcontainer.WSWebContainer.handleRequest(WSWebContainer.java:1662)
      at com.ibm.ws.webcontainer.channel.WCChannelLink.ready(WCChannelLink.java:195)
      at com.ibm.ws.ard.channel.ARDChannelConnLink.handleDiscrimination(ARDChannelConnLink.java:218)
      at com.ibm.ws.ard.channel.ARDChannelConnLink.ready(ARDChannelConnLink.java:123)
      at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleDiscrimination(HttpInboundLink.java:452)
      at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleNewRequest(HttpInboundLink.java:511)
      at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.processRequest(HttpInboundLink.java:305)
      at com.ibm.ws.http.channel.inbound.impl.HttpICLReadCallback.complete(HttpICLReadCallback.java:83)
      at com.ibm.ws.ssl.channel.impl.SSLReadServiceContext$SSLReadCompletedCallback.complete(SSLReadServiceContext.java:1784)
      at com.ibm.ws.tcp.channel.impl.AioReadCompletionListener.futureCompleted(AioReadCompletionListener.java:165)
      at com.ibm.io.async.AbstractAsyncFuture.invokeCallback(AbstractAsyncFuture.java:217)
      at com.ibm.io.async.AsyncChannelFuture$1.run(AsyncChannelFuture.java:205)
      at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1659)
      Caused by: java.lang.NullPointerException
      at com.ibm.ws.webcontainer.channel.WCCByteBufferOutputStream.linkHandledError(WCCByteBufferOutputStream.java:431)
      at com.ibm.ws.webcontainer.channel.WCCByteBufferOutputStream.write(WCCByteBufferOutputStream.java:103)
      at com.ibm.ws.webcontainer.srt.SRTOutputStream.write(SRTOutputStream.java:97)
      at sun.nio.cs.StreamEncoder$CharsetSE.writeBytes(StreamEncoder.java:355)
      at sun.nio.cs.StreamEncoder$CharsetSE.implWrite(StreamEncoder.java:416)
      at sun.nio.cs.StreamEncoder.write(StreamEncoder.java:159)
      at java.io.OutputStreamWriter.write(OutputStreamWriter.java:229)
      at com.ibm.wsspi.webcontainer.util.BufferedWriter.writeOut(BufferedWriter.java:497)
      at com.ibm.wsspi.webcontainer.util.BufferedWriter.write(BufferedWriter.java:330)
      at java.io.PrintWriter.write(PrintWriter.java:393)
      at net.jawr.web.resource.bundle.IOUtils.copy(IOUtils.java:54)
      at net.jawr.web.resource.bundle.IOUtils.copy(IOUtils.java:38)
      at net.jawr.web.resource.bundle.handler.ResourceBundlesHandlerImpl.writeBundleTo(ResourceBundlesHandlerImpl.java:414)
      at net.jawr.web.servlet.JawrRequestHandler.writeContent(JawrRequestHandler.java:675)
      at net.jawr.web.servlet.JawrRequestHandler.processRequest(JawrRequestHandler.java:607)
      at net.jawr.web.servlet.JawrRequestHandler.processRequest(JawrRequestHandler.java:504)
      at net.jawr.web.servlet.JawrRequestHandler.doGet(JawrRequestHandler.java:447)
      ... 26 more

        Activity

        icefox added a comment -

        Hi,

        This doesn't seems to be a Jawr issue.
        Jawr tries to read a bundle from the filesystem and write it to the response stream,
        but it seems that there is an issue on the web container.

        Without further information, I would say that there is an issue on the web application server,
        but that's all that I'll be able to say.

        Do you have more information or a specific test case?

        Cheers,

        icefox added a comment -

        We don't have enough information to investigate this issue


          People

          • Assignee:
            icefox
            Reporter:
            pinocchio1983
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: