jaxb
  1. jaxb
  2. JAXB-1004

Specific enum member ignored and Enum class not generated

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.2.7
    • Fix Version/s: None
    • Component/s: xjc
    • Labels:
      None

      Description

      Consider this XML snippet:

      <xs:simpleType name="uom">
      		<xs:restriction base="xs:string">
      			<xs:enumeration value="kg" />
      			<xs:enumeration value="m/s" />
      			<xs:enumeration value="m³" />
      			<xs:enumeration value="L" />
      		</xs:restriction>
      	</xs:simpleType>
      

      XJC simple does not generate the Enum Uom. If you change to m3 it works.

        Activity

        Iaroslav Savytskyi added a comment -

        Hi, Michael,

        I've tried this on trunk, on jaxb 2.2.7 and besides it takes quite long I always have positive result:

        Uom.java
        XmlType(name = "uom", namespace = "")
        @XmlEnum
        public enum Uom { 
        ...
         @XmlEnumValue("m\u00b3")
         M("m\u00b3"),
        ...
        }
        
        Michael Osipov added a comment -

        Thanks for the feedback. I tried several variations of it with XJC directly and through the Maven plugin and was not able to reproduce it anymore. Feel free to close as NOTABUG.


          People

          • Assignee:
            Iaroslav Savytskyi
            Reporter:
            Michael Osipov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: