jaxb
  1. jaxb
  2. JAXB-689

Element Substitution not working

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 2.1.12
    • Fix Version/s: not determined
    • Component/s: runtime
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      I've asked the mailing list and the forum but now answer, so thats why I have to
      submit an issue.

      We have two projects. Both of them using classes which was generated from valid
      schema by the xjc compiler. In Project 1 is an abstract element which will be
      substituted by other elements from project 2. When I run the application an try
      to unmarshal the valid instance file, the netbeans xml validator says it is
      valid, I always get an unexpected element exception which says that the element
      out of project 2 was not expected. It expected the abstract element from project
      1. But as I said, the element from project 2 substitutes the element from
      project 1. Either I'm missing something or I've found a bug.

      1. generic-jobengine.tar.gz
        962 kB
        hannehomuth
      2. jaxbTestCase.tar.gz
        37 kB
        hannehomuth

        Activity

        Pavel Bucek added a comment -

        duplicate of 620 (unmarshaling part)

            • This issue has been marked as a duplicate of 620 ***
        hannehomuth added a comment -

        Created an attachment (id=371)
        Minimal testcase showing describing my error

        hannehomuth added a comment -

        I just started to give the 2.2.1 Version a try. But the bug seems to be still
        existing in my opinion.

        I mean the error message is gone, but the unmarshal progress will not return the
        expected result.

        I've created a new testcase which should be better (my first one was very bad
        [Sorry])

        Pavel Bucek added a comment -

        thanks for new testcase!

        metro2.1-waived

        Martin Grebac added a comment -

        Hi,
        thanks for the testcase, but I'm getting:
        [ERROR] FATAL ERROR
        [INFO] ------------------------------------------------------------------------
        [INFO] Error building POM (may not be this project's POM).

        Project ID: com.vw.ais:using_abstract_engine:jar:1.0-SNAPSHOT

        Reason: Cannot find parent: com.vw.ais:generic-jobengine for project: com.vw.ais:using_abstract_engine:jar:1.0-SNAPSHOT for project com.vw.ais:using_abstract_engine:jar:1.0-SNAPSHOT

        MartiNG


          People

          • Assignee:
            Iaroslav Savytskyi
            Reporter:
            hannehomuth
          • Votes:
            1 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: