jaxb
  1. jaxb
  2. JAXB-800

Jaxb 2.2.1 - Incorrect packaging -

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.2.1
    • Fix Version/s: 2.2.1
    • Component/s: www
    • Labels:
      None

      Description

      Good morning,

      We have to use Jaxb v2.2.1 but the corresponding archive downloaded from http://jaxb.java.net/2.2.1/ seems to package Jaxb v2.1.13.

      Can you give us the correct download link for Jaxb 2.2.1 ?

      Thank you very much,
      Have a nice day.

        Activity

        Hide
        Martin Grebac added a comment -

        It's certainly the correct artifact. Why do you think it's wrong one? I think you may be using it incorrectly on JDK6 wrt the endorsed dir setup: http://jaxb.java.net/guide/Migrating_JAXB_2_0_applications_to_JavaSE_6.html#Using_JAXB_2_1_or_JAXB_2_2_with_JavaSE_6

        Show
        Martin Grebac added a comment - It's certainly the correct artifact. Why do you think it's wrong one? I think you may be using it incorrectly on JDK6 wrt the endorsed dir setup: http://jaxb.java.net/guide/Migrating_JAXB_2_0_applications_to_JavaSE_6.html#Using_JAXB_2_1_or_JAXB_2_2_with_JavaSE_6
        Hide
        yann.crueghe added a comment -

        Hi Martin,

        Here is the "xjc version" trace :

        xjc version "hudson-jaxb-ri-2.1-2"
        JavaTM Architecture for XML Binding(JAXB) Reference Implementation, (build hudso
        n-jaxb-ri-2.1-2)

        XJC seems to use a 2.1 version of jaxb instead of 2.2

        And here is the version declared into the JAXB libs :

        jaxb-api.jar's MANIFEST.MF :
        Specification-Title: Java Architecture for XML Binding
        Specification-Version: 2.1
        v2.1 instead of 2.2

        jaxb-impl.jar's MANIFEST.MF :
        Implementation-Version: 2.1.13
        v2.1.13 instead of 2.2.1

        Thank you Martin to take care about my issue.

        Show
        yann.crueghe added a comment - Hi Martin, Here is the "xjc version" trace : xjc version "hudson-jaxb-ri-2.1-2" JavaTM Architecture for XML Binding(JAXB) Reference Implementation, (build hudso n-jaxb-ri-2.1-2) XJC seems to use a 2.1 version of jaxb instead of 2.2 And here is the version declared into the JAXB libs : jaxb-api.jar's MANIFEST.MF : Specification-Title: Java Architecture for XML Binding Specification-Version: 2.1 v2.1 instead of 2.2 jaxb-impl.jar's MANIFEST.MF : Implementation-Version: 2.1.13 v2.1.13 instead of 2.2.1 Thank you Martin to take care about my issue.
        Hide
        Martin Grebac added a comment -

        I downloaded the artifact, ran the installer and the versions are correct in all manifests (2.2.1). So it must be something on your end.

        Show
        Martin Grebac added a comment - I downloaded the artifact, ran the installer and the versions are correct in all manifests (2.2.1). So it must be something on your end.
        Hide
        yann.crueghe added a comment -

        Thank you Martin.

        You're right, a proxy issue on my end.

        Sorry for the inconveninence and have a nice day.

        Show
        yann.crueghe added a comment - Thank you Martin. You're right, a proxy issue on my end. Sorry for the inconveninence and have a nice day.

          People

          • Assignee:
            Martin Grebac
            Reporter:
            yann.crueghe
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: