Issue Details (XML | Word | Printable)

Key: JAXB-903
Type: Bug Bug
Status: Resolved Resolved
Resolution: Incomplete
Priority: Major Major
Assignee: Iaroslav Savytskyi
Reporter: bcnithya
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
jaxb

xjc doesnt work fine with the FpML 5.2 version

Created: 16/May/12 07:18 PM   Updated: 20/Jan/13 02:02 PM   Resolved: 20/Jan/13 02:02 PM
Component/s: xjc
Affects Version/s: 2.2.5
Fix Version/s: None

Time Tracking:
Not Specified

File Attachments: 1. Zip Archive tdml.zip (221 kB) 17/May/12 01:26 PM - bcnithya


Tags:
Participants: bcnithya, Iaroslav Savytskyi and Martin Grebac


 Description  « Hide

I used xjc version 2.2.5 but could not generate the classes. Please investigate.



Martin Grebac added a comment - 17/May/12 12:20 PM

Hi, thanks. Would you please share more details / provide testcase?


bcnithya added a comment - 17/May/12 01:26 PM

Attached is the xsd on which I tried to run xjc.bat but gave error. I ran this with maven and I had no issues.
Thanks


Iaroslav Savytskyi added a comment - 17/May/12 04:02 PM

I was not able to reproduce an error.
I've executed xjc with tdml-main-DEV20120511.xsd and 1014 files have been generated. Is it OK?
If no - please give more details what and how do you execute.


bcnithya added a comment - 17/May/12 05:39 PM

Please download FpML version 4.7 and you should be able to recreate this issue.


bcnithya added a comment - 17/May/12 06:04 PM

Even FpML website comments that xjc is having issues.


Iaroslav Savytskyi added a comment - 20/Jan/13 02:02 PM

I'm going to close the bug - because from JAXB point of view everything works fine. May be there are some issues within FpML?