Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.7
    • Fix Version/s: 2.2.8 (JDK 8)
    • Component/s: xjc
    • Labels:
      None
    • Environment:

      Windows, German locale

      Activity

      hdelfs added a comment -

      Sorry, but the originally entered description got lost:

      The command line option "-fullversion" for the XJC does not work but displays an exception. This is caused by the ${build.number} property used in the resource bundle definitions for Driver.FullVersion in (probably) all locales.

      C:\Java\jaxb-ri-2.2.7\bin>xjc -fullversion
      classLoader = java.net.URLClassLoader@118f375
      SharedSecrets.getJavaNetAccess()=java.net.URLClassLoader$7@f84386
      Exception in thread "main" java.lang.IllegalArgumentException: can't parse argument number build.number
              at java.text.MessageFormat.makeFormat(MessageFormat.java:1339)
              at java.text.MessageFormat.applyPattern(MessageFormat.java:458)
              at java.text.MessageFormat.<init>(MessageFormat.java:350)
              at java.text.MessageFormat.format(MessageFormat.java:811)
              at com.sun.tools.xjc.Messages.format(Messages.java:54)
              at com.sun.tools.xjc.Driver.run(Driver.java:232)
              at com.sun.tools.xjc.Driver.run(Driver.java:200)
              at com.sun.tools.xjc.Driver._main(Driver.java:123)
              at com.sun.tools.xjc.Driver.access$000(Driver.java:80)
              at com.sun.tools.xjc.Driver$1.run(Driver.java:103)
      

      Also -version and -fullversion don't work with the xjc Ant task, which would be a nice enhancement.

      Iaroslav Savytskyi added a comment -

      Thank you for reporting.
      I've checked in jaxb 2.2.8 - it's fixed.

      Iaroslav Savytskyi added a comment -

      Fixed

      Iaroslav Savytskyi added a comment -

      We have migrated JAXB project to maven. So ant tasks are not as prioritized as before.


        People

        • Assignee:
          Iaroslav Savytskyi
          Reporter:
          hdelfs
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved: