jaxp
  1. jaxp
  2. JAXP-33

XSLTC has information loss in compare with Xalan

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: www
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      33

      Description

      The XSL transformation from OpenOffice.org XML (the predecessor of the
      OpenDocument Format) to XHTML does loose the majority of the CSS styles.

      Where is the reason?

        Activity

        Santiago Pericas-Geertsen added a comment -

        This appears to be the same as,

        http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6384805

        which I have failed to reproduce. I've also created a unit test for it here:

        https://jaxp-sources.dev.java.net/source/browse/jaxp-sources/jaxp-ri/src/unit-test/bug6384805/?
        sortby=log#dirlist

        Can you please see if you can modify the unit test to show the problem. We've looked at this one a few
        times and have been unable to reproduce it. I suspect that the stylesheet is not enough, you need
        something in your Java code (a specific Source and Result maybe) to reproduce the problem.

        Also please try the latest JAXP RI available from this site to make sure it isn't actually fixed. As I said
        above, the best approach at this point would be to modify the unit test to show the problem.

        Santiago Pericas-Geertsen added a comment -

        Assigning this to me.

        svanteschubert added a comment -

        Created an attachment (id=10)
        XSLT test stylesheet isolating a possible namespace issue

        svanteschubert added a comment -

        Created an attachment (id=9)
        XHTML export transformation \xslt\export\xhtml\ooo2xhtml.xsl with \testdocs\input.fsxw and results for xsltc.xhtml and xalan.xhtml, the latter should be merely the same


          People

          • Assignee:
            Santiago Pericas-Geertsen
            Reporter:
            svanteschubert
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: