jaxp
  1. jaxp
  2. JAXP-45

Need to get useful/proper Error messages

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: www
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      45

      Description

      While running WSpex Perf benchmarking tests where one of the include file is
      missing, I get following exception from jaxp, which is not useful at all. Error
      message should be useful so that users can find the real cause of the error.

      > ant -Dconfig=configs/all-jaxws-tango.xml run |tee run.log
      Buildfile: build.xml

      run:
      [java] Reading configuration file 'configs/all-jaxws-tango.xml' ...
      [java] Exception in thread "main" java.lang.RuntimeException:
      javax.xml.bind.UnmarshalException
      [java] - with linked exception:
      [java] [org.xml.sax.SAXParseException: An 'include' failed, and no
      'fallback' element was found.]
      [java] at com.sun.japex.ConfigFileMerger.<init>(ConfigFileMerger.java:79)
      [java] at com.sun.japex.Engine.start(Engine.java:117)
      [java] at com.sun.japex.Japex.run(Japex.java:155)
      [java] at com.sun.japex.Japex.main(Japex.java:127)
      [java] Caused by: javax.xml.bind.UnmarshalException
      [java] - with linked exception:
      [java] [org.xml.sax.SAXParseException: An 'include' failed, and no
      'fallback' element was found.]
      [java] at
      javax.xml.bind.helpers.AbstractUnmarshallerImpl.createUnmarshalException(AbstractUnmarshallerImpl.java:315)
      [java] at
      com.sun.xml.bind.v2.runtime.unmarshaller.UnmarshallerImpl.createUnmarshalException(UnmarshallerImpl.java:481)

        Activity

        Santiago Pericas-Geertsen added a comment -

        This issue has already been fixed. I can't easily find the related issue number or CR, but here is the
        putback:

        https://jaxp-sources.dev.java.net/source/browse/jaxp-sources/xml-xerces/java/src/com/sun/org/
        apache/xerces/internal/xinclude/XIncludeHandler.java?r1=1.3&r2=1.4


          People

          • Assignee:
            jaxp-issues
            Reporter:
            dpatil
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: