jax-rs-spec
  1. jax-rs-spec
  2. JAX_RS_SPEC-393

Clarify what happens to parameters of existing LinkBuilder when it is used to create another Link

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0
    • Component/s: model api
    • Labels:
      None

      Description

      As agreed with Marek

        Activity

        Marek Potociar added a comment -

        Added comment to API documentation of Link.Builder.build methods:

        The state of the builder is unaffected; this method may be called multiple times on the same builder instance.

        This is the same comment as we have in UriBuilder and matches the intended behavior of Link.Builder.


          People

          • Assignee:
            Unassigned
            Reporter:
            beryozkin_sergey
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: