jax-ws
  1. jax-ws
  2. JAX_WS-1046

Client received SOAP Fault from server: ProtocolException inCL_LH_S

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: handlers
    • Labels:
      None
    • Environment:

      jaxws 2.2.7, JDK PIT build8

      Description

      Around 16 backward Compatibilty tests were failing with JDK8 PIT Build

      Steps to reproduce:

      1)Check out the jaxws sqe test suite.
      2)Modify jaxws-test/config/setup-props.xml to use &j2se; at line 10
      3)Download, install and start the tomcat server.
      4)Download the attached properties file "bc-tomcat.properties" to run the tests .
      5)Modify the above properties file according to your local workspace
      6)now move to jaxws-test/src/handlers/handlers_wsdl_doclit
      7)Execute the command :
      ant clean build bc-deploy bc-runtest bc-generate-results -propertyfile <path-to>/bc-tomcat.properties
      8)You can see the failures

      If you run the above command using JDK7 PIT build, you wont see the failures.

      with JDK7 and before when there was an exception, ex.getMessage() used to return "Expected:ProtocolException inCL_LH_S",but after some changes( related to JAX_WS-1034), we are receiving "Client received SOAP Fault from server: ProtocolException inCL_LH_S Please see the server log to find more detail regarding exact cause of the failure."

        Issue Links

          Activity

          Sreekanth added a comment -

          The fix( w.rt. QE test code) for this would be similar to fix to JAXWS-1034.Since these tests are part of backward compatibility tests,I am not sure fixing the client side test code is appropriate.

          miroslav.kos added a comment -

          actually sources looks already to be fixed with JAX_WS-1034; the question is if, how and when should be binaries for BC tests rebuilt (after new release of JDK? by the last unsupported jdk~jdk5?)

          Martin Grebac added a comment -

          Best is to test against previous version - that's what JDK does - that means prebuild binaries with JDK6 and run on JDK7 build. Similarly prebuild with JDK7 and run on JDK8 build. If that is too complicated then it would be fine to prebuild with lowest supported JDK - that would be JDK6 at this point and run the same on JDK7 and JDK8.
          Onto whether the test code should be fixed and rebuilt in general - it should be certainly fixed if the test relies on particular proprietary feature - such as exception message content which AFAIU is this case.

          miroslav.kos added a comment -

          Sreekanth, will you take care of this issue?

          Sreekanth added a comment -

          Miran,I will take care of it.

          Sreekanth added a comment -

          made the necessary changes to the qe side jar files.

          Updated the jar file jaxws-test/bc/handlers_clients.jar file in jaxws-2-2-x-XjdkX-branch branch.Checked the backward compatibility tests against both JDK7 and JDK8 PIT builds.

          Sreekanth added a comment -

          Fixed the jar files in internal SQE Workspace.Now the backward compatibility tests are passing


            People

            • Assignee:
              Sreekanth
              Reporter:
              Sreekanth
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: