Issue Details (XML | Word | Printable)

Key: JAX_WS-912
Type: Bug Bug
Status: Closed Closed
Resolution: Won't Fix
Priority: Major Major
Assignee: Sreekanth
Reporter: Sreekanth
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
jax-ws

Server returned HTTP response code: 403 for URL

Created: 14/Dec/10 06:33 AM   Updated: 22/Dec/10 05:28 AM   Resolved: 22/Dec/10 04:58 AM
Component/s: wsimport
Affects Version/s: 2.2.2
Fix Version/s: None

Time Tracking:
Not Specified

File Attachments: 1. File context.war (61 kB) 14/Dec/10 06:33 AM - Sreekanth

Environment:

Linux,JDK 7, tomcat 5.5 jaxws 2.2.2


Tags:
Participants: Marek Potociar, ramapulavarthi and Sreekanth


 Description  « Hide

This test passes in earlier run [1] against .Now it is failing.

First deploy the app attached and try to do wsimport.

You will a response like:

[ERROR] Server returned HTTP response code: 403 for URL: http://localhost:8080/context/wsdl_SimplePortType1?wsdl

Failed to read the WSDL document: http://localhost:8080/context/wsdl_SimplePortType1?wsdl, because 1) could not find the document; /2) the document could not be read; 3) the root element of the document is not <wsdl:definitions>.

[ERROR] failed.noservice=Could not find wsdl:service in the provided WSDL(s):

At least one WSDL with at least one service definition needs to be provided.

Failed to parse the WSDL.

[1]http://hudson-sca.us.oracle.com/view/jdk-integration-PIT/job/jaxws-sqe-pit-linux-jdk7/jdk=JDK6.0,label=arti/lastSuccessfulBuild/artifact/jaxws-test/logs.none/resultValid.html#N73732



Sreekanth added a comment - 14/Dec/10 06:34 AM

assigning to rama.


ramapulavarthi added a comment - 14/Dec/10 10:54 AM

I could not reproduce the issue. The application deployed fine for me.
If you see a problem like this, that means the app did not deploy properly. Please attach server logs to see if there are any stacktraces for this deployment.


ramapulavarthi added a comment - 14/Dec/10 10:55 AM

Assigning it back to sreekanth for more information.


Sreekanth added a comment - 14/Dec/10 11:01 AM

Guess this is related to Proxy setting on my machine.Will look into it tomorrow.


Sreekanth added a comment - 22/Dec/10 04:58 AM

This is due to some proxy settings on my machine where I ran this test.It is passing now[1].So closing this issue

[1]http://ejp5355-vm2.india.sun.com:9999/view/JAXWS-PIT/job/JAXWS-SQE-JDK7PIT/32/artifact/jaxws-test/logs.none/resultValid.html#N73732


Marek Potociar added a comment - 22/Dec/10 05:28 AM

Closing