Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.2.1
    • Fix Version/s: 2.2.4
    • Component/s: wsimport
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      This issue relates to JAX_WS-354.

      Artifacts generated by wsimport containing Boolean object properties (as opposed to boolean primitives) have accessor methods that are named f.x. isFoo contrary to JavaBeans specification, only accessors to boolean primitives should be named "is" any accessor returning an object including Boolean objects should be named "get".

      This issue causes problems when trying to use accessors in JSP via EL for example. $

      {bean.foo}

      throws exception "no such method" in Tomcat if foo is defined as: "public Boolean isFoo();" whereas: "public boolean isFoo()" doesn't.

        Issue Links

          Activity

          jitu added a comment -

          Assigning this to MartinG

          Martin Grebac added a comment -

          Duplicate of jaxb131.


            People

            • Assignee:
              Martin Grebac
              Reporter:
              Samuel Santos
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: