jax-ws
  1. jax-ws
  2. JAX_WS-940

Modular databinding code causes error in GlassFish OSGi environment

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: 2.2.6
    • Component/s: jaxb
    • Labels:
      None

      Description

      Bhakti and Kumar were recently installing Metro trunk builds (including the latest JAX-WS 2.2.x build) on the AIX port of GlassFish 3.1.1 and that caused the following exception when deploying a web service:

      [#|2011-04-01T11:21:04.871-0700|SEVERE|glassfish3.2|javax.enterprise.system.tools.admin.org.glassfish.deployment.admin|_ThreadID=7;_ThreadName=Thread-8;|Exception while loading the app : java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: com.sun.xml.ws.transport.http.servlet.WSServletException: WSSERVLET11: failed to parse runtime descriptor: com.sun.xml.ws.spi.db.DatabindingException: Unknown Databinding mode: glassfish.jaxb|#]

      I doubt that this is related to AIX, it seems more likely an issue with OSGi class loading. The exception is thrown by com.sun.xml.ws.model.AbstractSEIModelImpl line 206 (method createJAXBContext()).

        Activity

        scchen added a comment -

        This is most likely caused by missing the com.sun.xml.ws.spi.db.BindingContextFactory service provider file in the META-INF/services, or for some reason the ServiceFinder cannot load that service provider file to get the BindingContextFactory implementations.

        ritzmann added a comment -

        Generally, META-INF/services lookups have been working fine for me. It seems more likely to me that the service finder is using the wrong classloader or the class to be loaded is not properly exported.

        Will post steps to reproduce.

        Martin Grebac added a comment -

        expected to be fixed - please reopen if the error still persists with metro promoted build > 2.2-b07


          People

          • Assignee:
            Martin Grebac
            Reporter:
            ritzmann
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: