jax-ws-commons
  1. jax-ws-commons
  2. JAX_WS_COMMONS-107

Default output folder of wsimport is not in target/generated-sources/...

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: current
    • Fix Version/s: 2.1, 2.2, 2.2.1, 2.3
    • Component/s: maven-plugin
    • Labels:
      None

      Description

      This enables Netbeans, and probably other IDE's to display the generated source code. And it is the maven convention.

      In this example

      <plugin>
      <groupId>org.codehaus.mojo</groupId>
      <artifactId>jaxws-maven-plugin</artifactId>
      <version>1.12</version>
      <executions>
      <execution>
      <id>generate-reports-ws-code</id>
      <phase>generate-sources</phase>
      <goals>
      <goal>wsimport</goal>
      </goals>
      <configuration>
      <packageName>com.example.myservice</packageName>
      <wsdlUrls>
      <wsdlUrl>http://localhost:8080/service/myservice?wsdl</wsdlUrl>
      </wsdlUrls>
      <verbose>true</verbose>
      </configuration>
      </execution>
      </executions>
      </plugin>

      you will need to add

      <sourceDestDir>$

      {basedir}

      /target/generated-sources/wsimport</sourceDestDir>

      which is not very "convention over configuration", the Maven hallmark

        Activity

        Lukas Jungmann added a comment -

        you are using obsolete version of the plugin which has been replaced by org.jvnet.jax-ws-commons:jaxws-maven-plugin, current version is 2.3 and following works for me there:

        <plugin>
            <groupId>org.jvnet.jax-ws-commons</groupId>
            <artifactId>jaxws-maven-plugin</artifactId>
            <version>2.3</version>
            <executions>
                <execution>
                    <id>generate-reports-ws-code</id>
                    <phase>generate-sources</phase>
                    <goals>
                        <goal>wsimport</goal>
                    </goals>
                    <configuration>
                        <packageName>com.example.myservice</packageName>
                        <wsdlUrls>
                            <wsdlUrl>http://localhost:8080/service/myservice?wsdl</wsdlUrl>
                        </wsdlUrls>
                        <verbose>true</verbose>
                    </configuration>
                </execution>
            </executions>
        </plugin>
        

        more info is available at https://jax-ws-commons.java.net/jaxws-maven-plugin/


          People

          • Assignee:
            Lukas Jungmann
            Reporter:
            xylifyx
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: