Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3.1
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:

      Windows

      Description

      [INFO] jaxws:wsimport args: [-keep, -s, D:\My Documents\SVN\app_layer\working\app_layer\src\main\java, -d, D:\My Documents\SVN\app_layer\working\app_layer\target\classes, -Xnocompile, "file:/D:/My%20Documents/SVN/app_layer/working/app_layer/src/main/resources/META-INF/wsdl/SomeService.wsdl"]
      directory not found: D:\My

        Activity

        predatorvi added a comment -

        I am seeing this as well. Our Jenkins_CI server job names are something like "myproject (currentbranch)".

        If I use jaxws-maven-plugin v2.1, it works fine. If I switch to jaxws-maven-plugin v2.2.1, it fails unless I change the job name to something without a space so something has changed in how the plugin passes command-line args to wsimport maybe?

        Lukas Jungmann added a comment -

        confirmed, fixing...

        hjohn added a comment -

        Is there any chance we could see a 2.3.1 release with this issue fixed? It's been almost a year since 2.3 and this bug is hitting us still forcing us to run this plugin from a path without spaces.

        We cannot downgrade to 2.2 as other plugins stop working then.

        zeiss added a comment -

        Would you please consider making a 2.3.1 release? It is not good to have the plugin failing in such a basic scenario.

        zeiss added a comment -

        Is it also possible to backport the fix to 2.2 line? I cannot use 2.3 in some builds for various reasons.


          People

          • Assignee:
            Lukas Jungmann
            Reporter:
            lkh007
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: