jcpnext4
  1. jcpnext4
  2. JCPNEXT4-32

Clarify the meaning of the term "conditional yes vote" in the Process Document

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Labels:
      None

      Description

      Section 5.2 of the Process Document uses the term "conditional yes vote". This should be explained. (It means that an EC member voted "yes" with a comment similar to "I'm not voting no now, but I expect issue X to be addressed in the future".)

        Issue Links

          Activity

          heathervc added a comment -

          We will address this as part of Issue #2 Definitions in JSR 364.

          pcurran added a comment - - edited

          Proposed fix

          No need for a formal definition.

          On lines 636-627:

          Change: "An issue that was referenced in a conditional yes vote during an earlier development stage has not been addressed."

          To: "An issue that was referenced in a conditional yes vote (when an EC member voted "yes" with a comment stating the expectation that it would be addressed in the future) has not been addressed."

          pcurran added a comment -

          Suggested text has been incorporated into version 1 of the revised Process Document.

          jpampuch added a comment -

          If this is intended to only apply to maintenance releases, then this issue is complete and can be closed. However, perhaps we want to consider the idea of "conditional yes" for regular reviews as well (perhaps in a future revision.)

          pcurran added a comment -

          It was intended to apply specifically to Maintenance Releases (we're addressing the specific - and deliberately limited - set of circumstances under which it is permissible for the EC to vote "no" on a Maintenance Release). (In earlier versions of the Process Document they had no such veto power, and could only require that a specific change be postponed until a new version of the JSR.

          It may well be that an EC member would cast a similar "conditional yes" vote at, for example, Public Review (the Process Doc is silent on this). Under those circumstances that member would presumably vote "no" at Final Release (or a subsequent additional Public Review) if the issue was not addressed.

          I believe this is fixed, and will close the issue.


            People

            • Assignee:
              pcurran
              Reporter:
              pcurran
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: