jersey
  1. jersey
  2. JERSEY-1296

Response#close() doesn't call the stream.close()

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0-m06
    • Fix Version/s: 2.0-m06, 2.0
    • Component/s: core
    • Labels:
      None

      Description

      Response#close javadoc says:

      Close the message entity input stream (if available and open).

      If the close() method is invoked before the message entity has been fully read from the input stream, any subsequent attempt to read the entity will result in an MessageProcessingException being thrown.

      But after close(), one can readEntity()
      and overriden close() on a provided InputStream is not called

        Issue Links

          Activity

          Martin Matula added a comment -

          Duplicate of JERSEY-1177

          jan.supol added a comment -

          I'd say JERSEY-1177 is a reason not equivalent for this issue. Solving 1177 doesn't necessary mean that calls of close() are added where appropriate


            People

            • Assignee:
              Jakub Podlesak
              Reporter:
              jan.supol
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: