jersey
  1. jersey
  2. JERSEY-1371

Ordering of annotations yields "HTTP Status 415 - Unsupported Media Type"

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.13
    • Fix Version/s: 1.14, 2.0
    • Component/s: None
    • Labels:
      None

      Description

      Method get1 yields "HTTP Status 415 - Unsupported Media Type" while method get2 works perfectly:

      @GET
      @Path("get1")
      @Validate
      public String get1(@QueryParam("x") @Min(5) Integer i)

      { return String.valueOf(2*i); }


      @GET
      @Path("get2")
      @Validate
      public String get2(@Min(5) @QueryParam("x") Integer i) { return String.valueOf(2*i); }

        Activity

        Martin Matula added a comment -

        I believe this is a duplicate of http://java.net/jira/browse/JERSEY-1352

        Michal, can you please verify?

        Michal Gajdos added a comment -

        Verified. The case described above is a duplicate of JERSEY-1352 (and is fixed in Jersey 1.14-SNAPSHOT and Jersey 2.0-m07).


          People

          • Assignee:
            Michal Gajdos
            Reporter:
            christof.doll
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: