jersey
  1. jersey
  2. JERSEY-1389

Encoding of parameters does not work correctly.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 2.0-m08, 2.0
    • Component/s: None
    • Labels:
      None

      Description

      The test:

      org.glassfish.jersey.server.internal.inject.EncodedParamTest

      is currently blocked by the issue JERSEY-1224 (constructor parameter injection does not work). But even with working constructor param injections (workaround) this test does not pass (problem with encoding).

      This issue should be fixed after the HK2 issue with InjectionResolver isfixed.

        Issue Links

          Activity

          Miroslav Fuksa added a comment -

          can be fixed after the JERSEY-1224 is resolved.

          Miroslav Fuksa added a comment -

          this is duplicate of JERSEY-986

          Miroslav Fuksa added a comment -

          closing as duplicate. The original issue is already fixed.


            People

            • Assignee:
              Unassigned
              Reporter:
              Miroslav Fuksa
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: