jersey
  1. jersey
  2. JERSEY-1505

Jersey does not print stack trace to application server error log any longer

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0-m09
    • Fix Version/s: 2.0-rc1, 2.0
    • Component/s: core
    • Labels:
      None

      Description

      for instance

      @Provider
      @Consumes(MediaType.WILDCARD)
      public class Reader implements MessageBodyReader<EntityForReader> {
      @Override
      	public boolean isReadable(Class<?> type, Type genericType,
      			Annotation[] annotations, MediaType mediaType) {
      		throw new NullPointerException();
              }
      	@Override
      	public EntityForReader readFrom(Class<EntityForReader> type,
      			Type genericType, Annotation[] annotations, MediaType mediaType,
      			MultivaluedMap<String, String> httpHeaders, InputStream entityStream)
      			throws IOException, WebApplicationException {
      		return null; //never get here
      	}
      
      @Path("resource")
      public class Resource {
      
      	@Path("plain")
      	@GET
      	public String plain() {
      		return "aaa";
      	}
      }
      

      This code returns 500; but no message in server log

        Activity

        jan.supol added a comment -

        I assume Jakub solved this one already

        Miroslav Fuksa added a comment -

        I have added logging of unmappable exceptions when I was developing JERSEY-1617. This looks to be working. Jakub also did some fix already (test ExceptionLoggingTest). I will also add test based on Jan's example and close the issue.

        Miroslav Fuksa added a comment -

        Cannot reproduce. I have added test. See other comments of this issue.


          People

          • Assignee:
            Miroslav Fuksa
            Reporter:
            jan.supol
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 3 hours
              3h
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 1 hour Time Not Required
              1h