jersey
  1. jersey
  2. JERSEY-1510

Link.toString() returns incorrect value - URI is missing

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0-m08
    • Fix Version/s: 2.0-m13, 2.0
    • Component/s: core
    • Labels:
      None
    • Environment:

      Glassfish 4 b58

      Description

      Link.toString() returns e.g. '; rel="edit"' instead of '<URI>; re="edit"'

      Also, when using Link.fromResourceMethod() the created URI reference is relative to the JAX-RS context URI. I would have expected an absolute URI.

        Activity

        Marek Potociar added a comment -

        Note that in the latest version of the API, the Link has changed significantly (e.g. it is an abstract class and not a final class). The change in implementation should take into account this issue that has been reported against original link impl.

        Marek Potociar added a comment -

        The issue is not reproducible anymore. I've added a unit test to verify this.


          People

          • Assignee:
            Marek Potociar
            Reporter:
            algermissen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 3 hours
              3h
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 1 hour Time Not Required
              1h