jersey
  1. jersey
  2. JERSEY-1628

Payloads are not logged in POST methods

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.12
    • Fix Version/s: 1.18
    • Component/s: core
    • Labels:
      None
    • Environment:

      Glassfish 3.1.2.2

      Description

      The HTTP header information is logged but not the payload. In our case, we are using XML, and the XML is not logged.

        Activity

        geturnerlmco added a comment -

        If forgot to add that a LoggingFilter is configured in the web.xml

        Michal Gajdos added a comment -

        Cannot reproduce with Jersey 1.18-SNAPSHOT:

        Nov 06, 2013 1:26:27 PM com.sun.jersey.api.container.filter.LoggingFilter filter
        INFO: 3 * Server in-bound request
        3 > POST http://localhost:9998/jaxb/XmlRootElement
        3 > user-agent: curl/7.21.4 (x86_64-apple-darwin10.7.3) libcurl/7.21.4 OpenSSL/0.9.7l zlib/1.2.5
        3 > host: localhost:9998
        3 > accept: */*
        3 > content-type: application/xml
        3 > content-length: 72
        3 >
        <jaxbXmlRootElement><value>xml root element</value></jaxbXmlRootElement>
        
        Nov 06, 2013 1:26:27 PM com.sun.jersey.api.container.filter.LoggingFilter$Adapter finish
        INFO: 3 * Server out-bound response
        3 < 200
        3 < Content-Type: application/xml
        3 <
        <?xml version="1.0" encoding="UTF-8" standalone="yes"?><jaxbXmlRootElement><value>xml root element</value></jaxbXmlRootElement>
        
        Michal Gajdos added a comment -

        Resolving as Cannot Reproduce. Feel free to re-open at any time with your test-case (if you're still experiencing the issue).


          People

          • Assignee:
            Michal Gajdos
            Reporter:
            geturnerlmco
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 3 hours
              3h
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 1 hour Time Not Required
              1h