jersey
  1. jersey
  2. JERSEY-1771

@ApplicationPath does not work in JerseyTests with Grizzly container.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 2.0-rc1, 2.0
    • Component/s: None
    • Labels:
      None

      Description

      There are tests of samples in jersey which currently can't run with grizzly test container factory and glassfish (or jetty) in the same time. This causes problems as we can't tests these samples during our jersey standard builds and also as a gf4-samples tests on hudson. See for example sse-item-store-webapp sample. The sample defines @ApplicationPath("resources") on ItemStoreApp. The problem is that when sample is run as a JerseyTest using Grizzly test container the "resource" path is ignored (it would also be ignored if it would have been defined in web.xml).

      The Application in Grizzly container need to be deployed under the specific path which currently does not work.

      Anyway, the sample needs to use @ApplicationPath("resources") and not just @ApplicationPath("/") as it has some html resources which need to be located on path "/".

        Issue Links

          Activity

          Pavel Bucek added a comment -

          required to deploy and test relevant Jersey examples on grizzly.


            People

            • Assignee:
              Pavel Bucek
              Reporter:
              Miroslav Fuksa
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: