jersey
  1. jersey
  2. JERSEY-1818

WADL Generation is broken for the GlassFish RESTful Admin Interface

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0-rc1
    • Fix Version/s: 2.0-rc2, 2.0
    • Component/s: extensions
    • Labels:
      None

      Description

      When requesting the WADL for the GF admin interface, I get the stack trace below. The command line I used is

      curl -vSs http://localhost:4848/management/application.wadl

      Stack trace:

      [2013-03-26T09:46:00.521-0500] [glassfish 4.0] [INFO] [NCLS-REST-00003] [javax.enterprise.admin.rest] [tid: _ThreadID=43 _ThreadName=admin-listener(1)] [timeMillis: 1364309160521] [levelValue: 800] [[
        An error occurred while processing the request. Please see the server logs for details.
      MultiException stack 1 of 4
      javax.ws.rs.ProcessingException: Error creating a JAXBContext for wadl processing.
      	at org.glassfish.jersey.server.wadl.internal.WadlApplicationContextImpl.<init>(WadlApplicationContextImpl.java:110)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
      	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
      	at java.lang.reflect.Constructor.newInstance(Constructor.java:525)
      	at org.glassfish.hk2.utilities.reflection.ReflectionHelper.makeMe(ReflectionHelper.java:1091)
      	at org.jvnet.hk2.internal.ClazzCreator.createMe(ClazzCreator.java:245)
      	at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:320)
      	at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
      	at org.jvnet.hk2.internal.SingletonContext.findOrCreate(SingletonContext.java:107)
      	at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
      	at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
      	at org.glassfish.jersey.internal.inject.ContextInjectionResolver.resolve(ContextInjectionResolver.java:104)
      	at org.jvnet.hk2.internal.ClazzCreator.resolve(ClazzCreator.java:192)
      	at org.jvnet.hk2.internal.ClazzCreator.resolveAllDependencies(ClazzCreator.java:215)
      	at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:312)
      	at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
      	at org.jvnet.hk2.internal.SingletonContext.findOrCreate(SingletonContext.java:107)
      	at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
      	at org.jvnet.hk2.internal.ServiceLocatorImpl.getService(ServiceLocatorImpl.java:573)
      	at org.jvnet.hk2.internal.ServiceLocatorImpl.getService(ServiceLocatorImpl.java:560)
      	at org.glassfish.jersey.internal.inject.Injections.getOrCreate(Injections.java:172)
      	at org.glassfish.jersey.server.model.MethodHandler$ClassBasedMethodHandler.getInstance(MethodHandler.java:185)
      	at org.glassfish.jersey.server.internal.routing.PushMethodHandlerRouter.apply(PushMethodHandlerRouter.java:105)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage._apply(RoutingStage.java:118)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage._apply(RoutingStage.java:121)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage._apply(RoutingStage.java:121)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage._apply(RoutingStage.java:121)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage.apply(RoutingStage.java:102)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage.apply(RoutingStage.java:62)
      	at org.glassfish.jersey.process.internal.Stages.process(Stages.java:197)
      	at org.glassfish.jersey.server.ServerRuntime$1.run(ServerRuntime.java:208)
      	at org.glassfish.jersey.internal.Errors$1.call(Errors.java:231)
      	at org.glassfish.jersey.internal.Errors$1.call(Errors.java:227)
      	at org.glassfish.jersey.internal.Errors.process(Errors.java:275)
      	at org.glassfish.jersey.internal.Errors.process(Errors.java:257)
      	at org.glassfish.jersey.internal.Errors.process(Errors.java:227)
      	at org.glassfish.jersey.process.internal.RequestScope.runInScope(RequestScope.java:317)
      	at org.glassfish.jersey.server.ServerRuntime.process(ServerRuntime.java:191)
      	at org.glassfish.jersey.server.ApplicationHandler.handle(ApplicationHandler.java:819)
      	at org.glassfish.jersey.grizzly2.httpserver.GrizzlyHttpContainer.service(GrizzlyHttpContainer.java:325)
      	at org.glassfish.admin.rest.adapter.RestAdapter$2.service(RestAdapter.java:318)
      	at org.glassfish.admin.rest.adapter.RestAdapter.service(RestAdapter.java:181)
      	at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:246)
      	at org.glassfish.grizzly.http.server.HttpHandler.runService(HttpHandler.java:191)
      	at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:168)
      	at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:189)
      	at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:288)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:206)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:136)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:114)
      	at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:77)
      	at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:838)
      	at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:113)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
      	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:564)
      	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:544)
      	at java.lang.Thread.run(Thread.java:722)
      Caused by: javax.xml.bind.JAXBException: Provider com.sun.xml.internal.bind.v2.ContextFactory not found
       - with linked exception:
      [java.lang.ClassNotFoundException: com.sun.xml.internal.bind.v2.ContextFactory not found by org.glassfish.jersey.core.jersey-server [205]]
      	at javax.xml.bind.ContextFinder.newInstance(ContextFinder.java:148)
      	at javax.xml.bind.ContextFinder.find(ContextFinder.java:361)
      	at javax.xml.bind.JAXBContext.newInstance(JAXBContext.java:446)
      	at javax.xml.bind.JAXBContext.newInstance(JAXBContext.java:409)
      	at org.glassfish.jersey.server.wadl.internal.WadlApplicationContextImpl.<init>(WadlApplicationContextImpl.java:102)
      	... 60 more
      Caused by: java.lang.ClassNotFoundException: com.sun.xml.internal.bind.v2.ContextFactory not found by org.glassfish.jersey.core.jersey-server [205]
      	at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1532)
      	at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:75)
      	at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1955)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
      	at javax.xml.bind.ContextFinder.safeLoadClass(ContextFinder.java:573)
      	at javax.xml.bind.ContextFinder.newInstance(ContextFinder.java:145)
      	... 64 more
      MultiException stack 2 of 4
      java.lang.IllegalStateException: Unable to perform operation: create on org.glassfish.jersey.server.wadl.internal.WadlApplicationContextImpl
      	at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:347)
      	at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
      	at org.jvnet.hk2.internal.SingletonContext.findOrCreate(SingletonContext.java:107)
      	at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
      	at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
      	at org.glassfish.jersey.internal.inject.ContextInjectionResolver.resolve(ContextInjectionResolver.java:104)
      	at org.jvnet.hk2.internal.ClazzCreator.resolve(ClazzCreator.java:192)
      	at org.jvnet.hk2.internal.ClazzCreator.resolveAllDependencies(ClazzCreator.java:215)
      	at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:312)
      	at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
      	at org.jvnet.hk2.internal.SingletonContext.findOrCreate(SingletonContext.java:107)
      	at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
      	at org.jvnet.hk2.internal.ServiceLocatorImpl.getService(ServiceLocatorImpl.java:573)
      	at org.jvnet.hk2.internal.ServiceLocatorImpl.getService(ServiceLocatorImpl.java:560)
      	at org.glassfish.jersey.internal.inject.Injections.getOrCreate(Injections.java:172)
      	at org.glassfish.jersey.server.model.MethodHandler$ClassBasedMethodHandler.getInstance(MethodHandler.java:185)
      	at org.glassfish.jersey.server.internal.routing.PushMethodHandlerRouter.apply(PushMethodHandlerRouter.java:105)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage._apply(RoutingStage.java:118)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage._apply(RoutingStage.java:121)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage._apply(RoutingStage.java:121)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage._apply(RoutingStage.java:121)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage.apply(RoutingStage.java:102)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage.apply(RoutingStage.java:62)
      	at org.glassfish.jersey.process.internal.Stages.process(Stages.java:197)
      	at org.glassfish.jersey.server.ServerRuntime$1.run(ServerRuntime.java:208)
      	at org.glassfish.jersey.internal.Errors$1.call(Errors.java:231)
      	at org.glassfish.jersey.internal.Errors$1.call(Errors.java:227)
      	at org.glassfish.jersey.internal.Errors.process(Errors.java:275)
      	at org.glassfish.jersey.internal.Errors.process(Errors.java:257)
      	at org.glassfish.jersey.internal.Errors.process(Errors.java:227)
      	at org.glassfish.jersey.process.internal.RequestScope.runInScope(RequestScope.java:317)
      	at org.glassfish.jersey.server.ServerRuntime.process(ServerRuntime.java:191)
      	at org.glassfish.jersey.server.ApplicationHandler.handle(ApplicationHandler.java:819)
      	at org.glassfish.jersey.grizzly2.httpserver.GrizzlyHttpContainer.service(GrizzlyHttpContainer.java:325)
      	at org.glassfish.admin.rest.adapter.RestAdapter$2.service(RestAdapter.java:318)
      	at org.glassfish.admin.rest.adapter.RestAdapter.service(RestAdapter.java:181)
      	at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:246)
      	at org.glassfish.grizzly.http.server.HttpHandler.runService(HttpHandler.java:191)
      	at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:168)
      	at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:189)
      	at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:288)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:206)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:136)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:114)
      	at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:77)
      	at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:838)
      	at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:113)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
      	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:564)
      	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:544)
      	at java.lang.Thread.run(Thread.java:722)
      MultiException stack 3 of 4
      java.lang.IllegalArgumentException: While attempting to resolve the dependencies of org.glassfish.jersey.server.wadl.internal.WadlResource errors were found
      	at org.jvnet.hk2.internal.ClazzCreator.resolveAllDependencies(ClazzCreator.java:227)
      	at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:312)
      	at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
      	at org.jvnet.hk2.internal.SingletonContext.findOrCreate(SingletonContext.java:107)
      	at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
      	at org.jvnet.hk2.internal.ServiceLocatorImpl.getService(ServiceLocatorImpl.java:573)
      	at org.jvnet.hk2.internal.ServiceLocatorImpl.getService(ServiceLocatorImpl.java:560)
      	at org.glassfish.jersey.internal.inject.Injections.getOrCreate(Injections.java:172)
      	at org.glassfish.jersey.server.model.MethodHandler$ClassBasedMethodHandler.getInstance(MethodHandler.java:185)
      	at org.glassfish.jersey.server.internal.routing.PushMethodHandlerRouter.apply(PushMethodHandlerRouter.java:105)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage._apply(RoutingStage.java:118)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage._apply(RoutingStage.java:121)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage._apply(RoutingStage.java:121)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage._apply(RoutingStage.java:121)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage.apply(RoutingStage.java:102)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage.apply(RoutingStage.java:62)
      	at org.glassfish.jersey.process.internal.Stages.process(Stages.java:197)
      	at org.glassfish.jersey.server.ServerRuntime$1.run(ServerRuntime.java:208)
      	at org.glassfish.jersey.internal.Errors$1.call(Errors.java:231)
      	at org.glassfish.jersey.internal.Errors$1.call(Errors.java:227)
      	at org.glassfish.jersey.internal.Errors.process(Errors.java:275)
      	at org.glassfish.jersey.internal.Errors.process(Errors.java:257)
      	at org.glassfish.jersey.internal.Errors.process(Errors.java:227)
      	at org.glassfish.jersey.process.internal.RequestScope.runInScope(RequestScope.java:317)
      	at org.glassfish.jersey.server.ServerRuntime.process(ServerRuntime.java:191)
      	at org.glassfish.jersey.server.ApplicationHandler.handle(ApplicationHandler.java:819)
      	at org.glassfish.jersey.grizzly2.httpserver.GrizzlyHttpContainer.service(GrizzlyHttpContainer.java:325)
      	at org.glassfish.admin.rest.adapter.RestAdapter$2.service(RestAdapter.java:318)
      	at org.glassfish.admin.rest.adapter.RestAdapter.service(RestAdapter.java:181)
      	at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:246)
      	at org.glassfish.grizzly.http.server.HttpHandler.runService(HttpHandler.java:191)
      	at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:168)
      	at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:189)
      	at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:288)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:206)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:136)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:114)
      	at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:77)
      	at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:838)
      	at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:113)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
      	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:564)
      	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:544)
      	at java.lang.Thread.run(Thread.java:722)
      MultiException stack 4 of 4
      java.lang.IllegalStateException: Unable to perform operation: resolve on org.glassfish.jersey.server.wadl.internal.WadlResource
      	at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:341)
      	at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
      	at org.jvnet.hk2.internal.SingletonContext.findOrCreate(SingletonContext.java:107)
      	at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
      	at org.jvnet.hk2.internal.ServiceLocatorImpl.getService(ServiceLocatorImpl.java:573)
      	at org.jvnet.hk2.internal.ServiceLocatorImpl.getService(ServiceLocatorImpl.java:560)
      	at org.glassfish.jersey.internal.inject.Injections.getOrCreate(Injections.java:172)
      	at org.glassfish.jersey.server.model.MethodHandler$ClassBasedMethodHandler.getInstance(MethodHandler.java:185)
      	at org.glassfish.jersey.server.internal.routing.PushMethodHandlerRouter.apply(PushMethodHandlerRouter.java:105)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage._apply(RoutingStage.java:118)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage._apply(RoutingStage.java:121)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage._apply(RoutingStage.java:121)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage._apply(RoutingStage.java:121)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage.apply(RoutingStage.java:102)
      	at org.glassfish.jersey.server.internal.routing.RoutingStage.apply(RoutingStage.java:62)
      	at org.glassfish.jersey.process.internal.Stages.process(Stages.java:197)
      	at org.glassfish.jersey.server.ServerRuntime$1.run(ServerRuntime.java:208)
      	at org.glassfish.jersey.internal.Errors$1.call(Errors.java:231)
      	at org.glassfish.jersey.internal.Errors$1.call(Errors.java:227)
      	at org.glassfish.jersey.internal.Errors.process(Errors.java:275)
      	at org.glassfish.jersey.internal.Errors.process(Errors.java:257)
      	at org.glassfish.jersey.internal.Errors.process(Errors.java:227)
      	at org.glassfish.jersey.process.internal.RequestScope.runInScope(RequestScope.java:317)
      	at org.glassfish.jersey.server.ServerRuntime.process(ServerRuntime.java:191)
      	at org.glassfish.jersey.server.ApplicationHandler.handle(ApplicationHandler.java:819)
      	at org.glassfish.jersey.grizzly2.httpserver.GrizzlyHttpContainer.service(GrizzlyHttpContainer.java:325)
      	at org.glassfish.admin.rest.adapter.RestAdapter$2.service(RestAdapter.java:318)
      	at org.glassfish.admin.rest.adapter.RestAdapter.service(RestAdapter.java:181)
      	at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:246)
      	at org.glassfish.grizzly.http.server.HttpHandler.runService(HttpHandler.java:191)
      	at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:168)
      	at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:189)
      	at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:288)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:206)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:136)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:114)
      	at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:77)
      	at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:838)
      	at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:113)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
      	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:564)
      	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:544)
      	at java.lang.Thread.run(Thread.java:722)
      ]]
      
      

        Issue Links

          Activity

          Marek Potociar added a comment -

          The JERSEY-1830 has been closed with the comment that the test should be added as part of work on this issue! The test should be thus added before the issue is closed. Adding a new test that tries to access the http://localhost:4848/management/application.wadl to the GF nucleus dev test suite and verifies the response code and content should be doable right?


            People

            • Assignee:
              Pavel Bucek
              Reporter:
              Jason Lee
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 6 hours
                6h
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 4 hours, 30 minutes Time Not Required
                4h 30m