jersey
  1. jersey
  2. JERSEY-1880

Jersey 2.0 incompatible with Eclipse Equinox Server-Side

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 2.0-rc2
    • Fix Version/s: 2.2
    • Component/s: core
    • Labels:
      None
    • Environment:

      Eclipse Equinox 3.8+

      Description

      Jersey dependes on the osgi package javax.servlet 3.0 because the servlet spec version is mapped 1 to 1 to the package version. This prevents using jersey together with the Eclipse Equinox Servlet bridge. This bridged is used to be able to pack an OSGi based application into a war.

      When deploying such a war file to a servlet container the bridge generates a bundel that provides the javax.servlet package for other OSGi bundles. Within this generation process the javax.servlet spec version is read and mapped. Spec version 3 matches package version 2.6. I have opened a bug against Eclipse Equinox regarding this mapping.

      But I think it would be good to decrease the version minium within the jersey servlet import too. The equinox bug can be found here https://bugs.eclipse.org/bugs/show_bug.cgi?id=407175

      Maybe we can collaborate to gain a good integration for Equinox Kepler and Jersey 2.0.

        Activity

        Marek Potociar added a comment -

        Thanks for the offer on contribution - please check here for details how to contribute to Jersey: https://jersey.java.net/contribute.html

        Moving the issue to Jersey 2.0 backlog for now.

        Marek Potociar added a comment -

        After evaluation, it seems the issue is invalid. In Jersey 2.x we provide 2 Servlet modules:

        1. jersey-servlet-core - depends on Servlet 2.5, is enough if you don't need JAX-RS 2.0 server-side async support.

        2. jersey-servlet - extends the core module and adds async support and thus needs to depend on the Servlet 3 API.


          People

          • Assignee:
            Unassigned
            Reporter:
            hstaudacher
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: