jersey
  1. jersey
  2. JERSEY-1970

fix regression in GF: WADL generation for GF REST API

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2
    • Component/s: None
    • Labels:
      None

      Description

      This is due to missing AccessController.doPrivileged calls in core-server/src/main/java/org/glassfish/jersey/server/wadl/internal/WadlApplicationContextImpl.java
      Th regression was caused by fix for JERSEY-1929

        Activity

        Jakub Podlesak added a comment -

        How to reproduce: start GF with Jersey 2.1-SNAPSHOT integrated and open http://localhost:4848/management/application.wadl


          People

          • Assignee:
            Jakub Podlesak
            Reporter:
            Jakub Podlesak
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: