Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Complete
    • Affects Version/s: 1.18
    • Fix Version/s: 1.19.1, 1.20
    • Component/s: core
    • Labels:
      None

      Description

      The following error only occurs when building under JDK8, not JDK7.

      Scanning for projects...
      The build could not read 1 project -> [Help 1]
        
        The project com.sun.jersey.samples:spring-annotations:1.18.1 (C:\Users\Gili\Documents\jersey1\samples\spring-annotations\pom.xml) has 2 errors
          'dependencies.dependency.version' for org.aspectj:aspectjrt:jar must be a valid version but is '${aspectjrt.version}'. @ line 114, column 22
          'dependencies.dependency.version' for org.aspectj:aspectjweaver:jar must be a valid version but is '${aspectjrt.version}'. @ line 120, column 22
      

      To fix this, you need to edit pom.xml in the spring-annotations project and add profile activation for JDK8 (currently only JDK6 and JDK7 are listed).

        Activity

        Hide
        Michal Gajdos added a comment -

        Moving to 1.19.

        Show
        Michal Gajdos added a comment - Moving to 1.19.
        Hide
        cowwoc added a comment -
        Show
        cowwoc added a comment - See https://github.com/jersey/jersey-1.x/pull/12 for a push request.
        Hide
        Marek Potociar added a comment -

        Jersey 1.x branch is not under active development anymore. Only security issues and issues reported by the customers of commercially supported products that ship with Jersey are fixed on this code base right now.
        Please, move your code to Jersey 2.x and if you still see the issue there, feel free to file a bug against Jersey 2.x.

        Show
        Marek Potociar added a comment - Jersey 1.x branch is not under active development anymore. Only security issues and issues reported by the customers of commercially supported products that ship with Jersey are fixed on this code base right now. Please, move your code to Jersey 2.x and if you still see the issue there, feel free to file a bug against Jersey 2.x.

          People

          • Assignee:
            Unassigned
            Reporter:
            cowwoc
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: