jersey
  1. jersey
  2. JERSEY-927

Package name resource config does not work in OSGi environment

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.8
    • Fix Version/s: 1.17
    • Component/s: core
    • Labels:
      None

      Description

      I am not able to run Jersey OSGI WAB with PackagenamesResourceConfig in Apache Felix or Equinox.
      I tried in jersey 1.8, 1.9 and 1.10.

      <init-param>
      <param-name>com.sun.jersey.config.property.resourceConfigClass</param-name>
      <param-value>com.sun.jersey.api.core.PackagesResourceConfig</param-value>
      </init-param>
      <init-param>
      <param-name>com.sun.jersey.config.property.packages</param-name>
      <param-value>com.sun.jersey.samples.helloworld</param-value>
      </init-param>

        Issue Links

          Activity

          saikirandaripelli added a comment -

          Steps to Reproduce:

          1. Download sample osgi app from https://maven.java.net/service/local/artifact/maven/redirect?r=releases&g=com.sun.jersey.samples&a=helloworld-osgi-webapp&v=1.11&c=project&e=zip

          2. un-zip it.

          3. open helloworld-osgi-webapp-1.11/war-bundle/src/main/webapp/WEB-INF/web.xml

          4. replace the init-params of "Jersey Web Application" servlet with one specified n Jira description.

          5. Follow /helloworld-osgi-webapp-1.11/README.html and deploy it to Felix or Equinox and try to access the resource.

          Pavel Bucek added a comment -
          Pavel Bucek added a comment -

          duplicate


            People

            • Assignee:
              Jakub Podlesak
              Reporter:
              saikirandaripelli
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: