jms-spec
  1. jms-spec
  2. JMS_SPEC-103

A JMS 2.0 resource adapter needs to be able to include cluster name in a generated subscription name

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0PD
    • Fix Version/s: None
    • Labels:
      None

      Description

      The draft JMS 2.0 specification, chapter 12.1. "ActivationSpec properties" states that:

      If a durable subscription is specified but subscriptionName is not specified then the resource adapter will set the name of the durable subscription to be a name which is unique to the deployed MDB.

      The intention of this feature is to allow the resource adapter to automatically generate a subscription name automatically which will be different for each deployed MDB but the same for each instance in the cluster. This instances of the same deployed MDB across the whole cluster to share the work of processing messages from the same subscription.

      However if the same JMS provider is being used by two different application server clusters, and the two clusters are using the same MDB name, then this would cause the two clusters to share the same subscription which is undesirable.

      To avoid this, the subscription name generated by the resource adapter should be composed of (1) a name which uniquely identifies the deployed MDB within thin the cluster as well as (2) a name which uniquely identifies the application server cluster.

      The JMS specification needs to be extended to cover (2)

        Issue Links

          Activity

          Nigel Deakin added a comment -

          This will also require a change to the EJB 3.2 specification which contains a similar definition of what the container does it the subscriptionName property is not set.

          Implementing this will require a change to the Java EE specification to make the name of the cluster available.

          Nigel Deakin added a comment -

          This is an extension of issue JMS_SPEC-73

          Nigel Deakin added a comment -

          I'm closing this issue as a duplicate of JMS_SPEC-73 because that issue is still open and it is best to keep this as a single open issue.


            People

            • Assignee:
              Nigel Deakin
              Reporter:
              Nigel Deakin
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: