jms-spec
  1. jms-spec
  2. JMS_SPEC-106

Methods on JMSContext that are disallowed if the context is injected should throw a IllegalStateException not a JMSException

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0PD
    • Fix Version/s: 2.0PD, 2.0
    • Labels:
      None

      Description

      Section 11.3.5. "Restrictions on use of injected JMSContext objects" of the draft JMS 2.0 specification lists some methods which may not be used if the JMSContext is injected (container-managed). It specifies that these methods must throw a JMSRuntimeException if the JMSContext is injected.

      A better exception to throw would be an IllegalStateRuntimeException since the error is caused by the JMSContext being "in the wrong state" (container-managed).

        Issue Links

          Activity

          Nigel Deakin created issue -
          Nigel Deakin made changes -
          Field Original Value New Value
          Link This issue blocks MQ-240 [ MQ-240 ]
          Nigel Deakin added a comment -

          API docs and spec now updated.

          Nigel Deakin made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Assignee Nigel Deakin [ nigeldeakin ]
          Fix Version/s 2.0PD [ 16049 ]
          Resolution Fixed [ 1 ]
          Nigel Deakin made changes -
          Tags pd20-added
          Nigel Deakin made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          Nigel Deakin made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Fix Version/s 2.0 [ 14692 ]
          Resolution Fixed [ 1 ]

            People

            • Assignee:
              Nigel Deakin
              Reporter:
              Nigel Deakin
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: